Find the answer to your Linux question:
Results 1 to 2 of 2
cat /proc/version Linux version 2.6.9-42.ELsmp (buildcentos@mehak.karan.org) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP I have another machine running Ubuntu 5.10 as a fileserver running NFS-kernel-server. When I first ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Question NFS mounts owned by 'amanda' and inaccessible even to root...


    cat /proc/version
    Linux version 2.6.9-42.ELsmp (buildcentos@mehak.karan.org) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP


    I have another machine running Ubuntu 5.10 as a fileserver running NFS-kernel-server. When I first mounted some folders onto my centos machine all was well. I could access files, change files, everything. Then I noticed that I couldn't access those files through php scripts. I figured it was because the apache user on ubuntu is www-data and the centos user is apache so I had to give sufficient access. To test this I gave every file 766 permissions. When it had finished, things were worse. Now I can't even cd below the top level of the mount; it says permission denied when I try (even as root). I checked permissions with ls -l and it showed that everything was owned by amanda. But the folder I was trying to access had 766 permissions. I can't figure this out.

    if I su amanda I can get access but that's ridiculous. I need for apache to have access...as well as anything else I want in the future.

    I know that amanda is some kind of backup tool...but I didn't even know it was on my system...let alone why it took over my NFS mounts. I am not trying to backup anything, I'm just trying to have network access to remote files. How can I disable amanda or loosen her grips on my files?

    Another note, on my ubuntu box all the files retain their proper permissions, owner (www-data), and are fully accessible. This is completely blocking me from finishing my work. I appreciate any help. Thanks.

  2. #2
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Thumbs up squash

    It was a root squashing issue. I was mounting it as root (in /etc/fstab). I've made changes and have access now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •