Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
ethereal is not installed I didn't really get all this arping stuff.. what exactly address should I arp and what all this has to do with MAC addresses if you ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2007
    Posts
    12

    ethereal is not installed

    I didn't really get all this arping stuff.. what exactly address should I arp and what all this has to do with MAC addresses if you can direct me to some good arping guide it would be great..

    my last question is: do you think that without all this arping system I wouldn't be able to install this little simple network between 2 comps? that's quite weird because I thought linux nowadays supports all this networking issues without too much headaches.. I just thought that I'll need to configure my eth so it will be the server and the other eth that connects to my parents' computer.. but I guess it would be a dirty work for a quite little home-network.

  2. #12
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    To ethereal: maybe tcpdump is installed. I saw that this has improved in regard of easy use and translating headers into English words, too, with newer versions of Linux.

    The arping stuff is only to see exactly what Ethernet device you are using. ifconfig shows you a MAC address. With the arping stuff you can verify that. This is only for not to say: "I send a ping but nothing happens".

    It's with an electric circuit. If you have a bulb that doesn't work you need to measure the voltage or take the bulb out and measure the resistance. Otherwise, guessing can be very tedious.

    But best thing is to open a new thread as what you want is not simply a network connection only. Ask for connecting a Windows box to your Linux box with ADSL modem for Internet connection.
    Bus Error: Passengers dumped. Hech gap yo'q.

  3. #13
    Just Joined!
    Join Date
    Mar 2007
    Posts
    12
    look, i've been suggested a way that looked quite good but I had a problem with that:

    look, it what i was suggested:

    " You need to:
    * Be sure you can assign an adress to eth0 (marvell)

    ifconfig eth0 192.168.100.254 up

    This will ensure that the marvell network driver is working. If it doesn't work, you might need to use a very recent kernel (you can still keep your old one for rescue)

    * Activate the forwarding of packet between eth0 and eth1

    echo 1 >/proc/sys/net/ipv4/ip_forward

    * Activate network translation
    iptables -t nat -A POSTROUTING -s 192.168.100.0/24 -o eth1 -j MASQUERADE

    * On the windows machine, assign an IP of 192.168.100.1 , netmask 255.255.255.0. Gateway is 192.168.100.254 (eth0).
    For the DNS, you need the same 2 nameservers that were automatically assigned to your linux (IP adresses are in /etc/resolv.conf on the gateway)

    * Check from the XP (as soon as there is an error, no need to go on, it won't work)
    ping 192.168.100.1 (internal check)
    ping 192.168.100.254 (connectivity to Gateway)
    ping 209.85.129.99 (that's the IP of www.l.google.com)
    ping www.google.com (see if DNS works)
    Remove IE, Use Firefox (general rule )


    That's ONE setting.
    Improvement can be:
    -> If your XP ONLY need webbrowsing then putting a local small HTTP proxy on gateway is a good security measure (I do this) The proxy will be on the gateway and will forward only HTTP/FTP traffic to outside.

    -> Automatic configuration of DNS/IPs on XPs (dnsmasq maybe)

    -> Thigthening the firewall on gateway. "



    and my reply to that was :

    "im surfing through eth1 (the rtl8139) so should I assign the 192.168.100.254 address to the net adapter im surfing with or to the net adapter that connects to my parents' comp (in this case, marvell).. I know that u typed clearly ("Be sure you can assign an adress to eth0 (marvell)") but I had a typo in my first msg when I said that im surfing through eth0.. that was an mistake, im surfing through eth1 (rtl8139), and the eth0 is connected to my parents' computer..
    so I still must to :
    ifconfig 192.168.100.254 eth0 ?
    (to the marvell net adapter to connects to the other XP box)

    the second question is :
    when I type the iptables command I get this error:


    root@darkstar:~# iptables -t nat -A POSTROUTING -s 192.168.100.0/24 -o eth1 -j MASQUERADE
    FATAL: Module ip_tables not found.
    iptables v1.3.5: can't initialize iptables table `nat': iptables who? (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.


    im using slackware 11 with a quite updated kernel (2.6.17.13) so I don't think that this is the problem.."


    maybe you may help me with that..
    thank again (:

  4. #14
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Quote Originally Posted by gonroise
    so I still must to :
    ifconfig 192.168.100.254 eth0 ?
    (to the marvell net adapter to connects to the other XP box)

    the second question is :
    when I type the iptables command I get this error:


    root@darkstar:~# iptables -t nat -A POSTROUTING -s 192.168.100.0/24 -o eth1 -j MASQUERADE
    FATAL: Module ip_tables not found.
    iptables v1.3.5: can't initialize iptables table `nat': iptables who? (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.
    1. question:
    I think yes. At least, leave the eth1 with the ADSL untouched.

    2. question:
    Look where iptables resides with "which iptables". On my boxes it is "/sbin/iptables" and you have to be root to be able to launch it.
    Bus Error: Passengers dumped. Hech gap yo'q.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •