Find the answer to your Linux question:
Results 1 to 4 of 4
I'm sure that I've overlooked something or done something silly, but whenever I try to connect ssh with a different port (specified in sshd_config) than the standard port 22, the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Aug 2005
    Posts
    408

    ssh port problem--Solved


    I'm sure that I've overlooked something or done something silly, but whenever I try to connect ssh with a different port (specified in sshd_config) than the standard port 22, the terminal I'm trying to connect with just hangs.

    On the command:
    ssh -p 3497 user@192.168.1.2

    I get no response.

    I can connect when I leave it (in both sshd_config and on the terminal) at the default port, port 22, but with no other port, apparently.

    Also, I scanned through /etc/services to see which ones may be in use elsewhere.
    Last edited by eraker; 03-15-2007 at 10:37 PM. Reason: problem solved

  2. #2
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    I have two sshd on my firewall. One listens on port 22 to the internal network, one listens to port x to the outside. The only thing I changed was to create a second sshd_config which mainly has a different 'Port x' line. I expect that's what you did. Is there any FW in between the systems which passes port 22 but not port x?
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Are you firewalled? Maybe port 22 is open, and the others aren't. Did you restart sshd after making the changes (sorry, have to ask )

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Aug 2005
    Posts
    408
    Aha! I didn't open the port I was using on the firewall.

    That was it. I knew it was something I had just overlooked.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •