Find the answer to your Linux question:
Results 1 to 4 of 4
Hi. I run Debian unstable on a 1,7GHz Celeron (main board MSI MS-7005). Linux 2.6.19. I recently upgraded my memory from 512MB to 1GB, and now TCP/IP networking freezes when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    Network problem after upgrading memory


    Hi.

    I run Debian unstable on a 1,7GHz Celeron (main board MSI MS-7005).
    Linux 2.6.19.
    I recently upgraded my memory from 512MB to 1GB, and now TCP/IP networking freezes when transfering data from certain internet hosts. When fetching web pages etc., from other hosts, all is well.
    This is not just related to port 80. When I ssh to my mailserver machine (located on the other side of the atlantic,) I can log in, but it freezes up while running pine. With the web browser, it will start to fetch data, but freeze a moment later. It seems repeatable, that is, it seems to freeze at the same spot every time.

    Machine is othervise stable.

    When booting into windows, or lowering memory back to 512MB, the problem dissapears. I have also tried with a separate network card (I normally use the main board networking adapter,) but with the same results.

    Do you have any hints as to how I could best analyze this problem?

    Regards,
    Anders Bolager

  2. #2
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    First thing I would do is to test the memory.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    Network problem after upgrading memory

    Thanks for the tip, but I ran memtest86+ one whole night, and it didn't find a single error.
    I've also tried to boot a KUbuntu CD, which appears to work correctly, which seems to indicate a configuration or kernel problem.
    I run a self compiled but quite default configured kernel. I've also tried a recent Debian kernel I have installed, but with the same results.

    I guess I'll have to diff /etc on my root drive with the KUbuntu CD.

    Any other pointers?

    Regards,
    Anders Bolager

  4. #4
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    Smile Problem solved

    Hi

    I found a solution to my problem here.
    http://articles.techrepublic.com.com...1-6174075.html

    Regards,
    Anders

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •