Find the answer to your Linux question:
Results 1 to 10 of 10
Most common question, how to connect to internet using standard winmodem. I read some infos, but it still isn't working. Here's what I do: 1. I got newly scanModem.sh and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    13

    Connecting to Internet via modem


    Most common question, how to connect to internet using standard winmodem. I read some infos, but it still isn't working.
    Here's what I do:
    1. I got newly scanModem.sh and it detected my Modem as Lucent/Ageere, which is correct since that Win Xp is detecting it as Lucent WinModem.
    2. Since I got kernel 2.6.15-23-386 it says it need those Martian drivers to work so I downloaded needed tarball (martian-full-20061203.tar.gz)
    3. Installed needed kernel/linux headers, make application and gcc C compiler and compilation went without any probelms (or it isn't?). I used standard commands: make, sudo make install.
    4. Got GNOME-ppp to work and under options it auto-detected my modem as /dev/ttyLTM0 which was not in settings combobox.
    5. When I enter dial number (user and password along) and dialed number, I didn't hear modem dialing (like he is doing in XP) and log says "sending password" and there it does nothing.
    What I am doing wrong?

  2. #2
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    I don't have much a clue, but first thing could be switching the sound of the modem on.

    On my kppp, the sound is switched off by default. To switch it on, there is a button "modem volume" in section "Modem" after pressing the button "Setup".
    Bus Error: Passengers dumped. Hech gap yo'q.

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    13
    There is no such option in Gnome-PPP (or I don' see it).
    Also when I try to re-connect with /dev/ttyLTM0, it says that modem is not responding, while only the first time it tries to send password, and then nothing, as the modem was blocked or something.
    I read something about that modprobe martian_dev must be run each time Linux is booted, but still nothing.

  4. #4
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    But it is impossible that you cannot change the volume of the modem. This is an essential feature.

    Maybe you can change it in "modem commands" or the like. There must be something in plain English or there is a field for inserting something wit L1 to L3. "ML*" or "^L*" or the like. It's in the Hayes command set.

    Without sond and debug output it's really a guessing game, overall when debugging remotely over an Internet forum.
    Bus Error: Passengers dumped. Hech gap yo'q.

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    13
    You were right! There is a option to chose mode sound, but I didn't see in the first place. Still though there is no sound from modem.
    I read more closely documentation about martian modem driver, and found that modprobe martian_dev and sudo martian_modem must be call each time when I want to connect. Last command makes block device to modem to /dev/ttySM0, which dialer program must use.
    When I hit detect, Gnome-ppp choses ttyLTM0 as my modem.
    Here is an out from gnome-ppp detection progress.
    Code:
    GNOME PPP: STDOUT: Editing `/dev/null'.
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT: Scanning your serial ports for a modem.
    GNOME PPP: STDOUT:
    GNOME PPP: STDERR: Modem Port Scan<*1>: Scanning ttyLTM0 first, /dev/modem is a link to it.
    GNOME PPP: STDERR: WvModem<*1>: Cannot set information for serial port.
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 Z -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 S0=0 -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Modem Identifier: ATI -- LT V.92 Data+Fax Modem Version 8.31
    GNOME PPP: STDERR: ttyLTM0<*1>: Speed 4800: AT -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Speed 9600: AT -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Speed 19200: AT -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Speed 38400: AT -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Speed 57600: AT -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Speed 115200: AT -- OK
    GNOME PPP: STDERR: ttyLTM0<*1>: Max speed is 115200; that should be safe.
    GNOME PPP: STDERR: ttyLTM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
    GNOME PPP: STDERR: WvModem<*1>: Cannot set information for serial port.
    GNOME PPP: STDERR: ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
    GNOME PPP: STDERR: ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
    GNOME PPP: STDERR: ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.GNOME PPP: STDERR: WvModem<*1>: Cannot set information for serial port.
    GNOME PPP: STDERR: ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
    GNOME PPP: STDERR: ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
    GNOME PPP: STDERR: ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.GNOME PPP: STDERR: Modem Port Scan<*1>: S2   S3   S4   S5   S6   S7   S8   S9
    GNOME PPP: STDERR: Modem Port Scan<*1>: S10  S11  S12  S13  S14  S15  S16  S17
    GNOME PPP: STDERR: Modem Port Scan<*1>: S18  S19  S20  S21  S22  S23  S24  S25
    GNOME PPP: STDERR: Modem Port Scan<*1>: S26  S27  S28  S29  S30  S31  S32  S33
    GNOME PPP: STDERR: Modem Port Scan<*1>: S34  S35  S36  S37  S38  S39  S40  S41
    GNOME PPP: STDERR: Modem Port Scan<*1>: S42  S43  S44  S45  S46  S47
    GNOME PPP: STDERR: WvModem<*1>: Cannot get information for serial port.
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 -- OK
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 Z -- OK
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 S0=0 -- OK
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Modem Identifier: ATI -- LT V.92 Data+Fax Modem Version 8.30
    GNOME PPP: STDERR: ttySM0<*1>: Speed 4800: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 9600: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 19200: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 38400: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 57600: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 115200: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 230400: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Speed 460800: AT -- OK
    GNOME PPP: STDERR: ttySM0<*1>: Max speed is 460800; that should be safe.
    GNOME PPP: STDERR: ttySM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
    GNOME PPP: STDOUT:
    GNOME PPP: STDERR: ttyLTM0<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
    GNOME PPP: STDOUT: Found a modem on /dev/ttyLTM0, using link /dev/modem in config.
    GNOME PPP: STDERR: ttySM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
    GNOME PPP: STDOUT: Modem configuration written to /dev/null.
    Still I cannot connect to net since it stops when it sends passwords. On my Internet provider you first connect to him and then he verifies password (after squeaky modem sound). However there is still no sound from modem. Here is the out when I try to connect:
    Code:
    GNOME PPP: Connecting...
    GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by  hand!"
    GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.55
    GNOME PPP: STDERR: --> Cannot get information for serial port.
    GNOME PPP: STDERR: --> Initializing modem.
    GNOME PPP: STDERR: --> Sending: ATZ
    GNOME PPP: STDERR: ATZ
    GNOME PPP: STDERR: OK
    GNOME PPP: STDERR: --> Modem initialized.
    GNOME PPP: STDERR: --> Please enter password (or empty password to stop):
    And then it goes to infinity if I don't quit him.
    Also I noticed that after I cannot log out from my account normally and that I need to go to virtual terminal, log in and execute sudo shutdown -r.
    My guess that I'am not loading those drivers to kernel as it shoud be.

  6. #6
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    In the debug output, I don't see any AT command that deals with the modem volume. It should be something with L* or M* (* from 1 to 3).

    The computer commnicates with a modem via the Hayes command set:

    http://en.wikipedia.org/wiki/Hayes_command_set

    It's worth to have a look at this to see what your computer sends to the modem.

    The sound moght be not that much important as we have the debug output.

    I don't see that the modem is dialling at all. There should be an ATDT command following by the phone number you're dialling to.

    Asking for a password at this stage might be only a security feature of your dialling program.

    Generally, after sending "ATZ" and waiting for the string "OK" you're sending the command "ATDTxxxxx" with xxxxx being the phone nymber to the modem.

    With sound on, you hear often a clic and then you hear the modem dialling.

    If the modem would get stuck for whatever reason with the ATDT command there is a timeout and you would see an error messages like "BUSY" or the like.

    But you don't get to this point. I guess you need first to overcome that hurdle with this mysterious password.
    Bus Error: Passengers dumped. Hech gap yo'q.

  7. #7
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2

    Connecting to internet via modem

    I know this thread is a few months old, but I thought I'd drop a piece of advice for any body that may still using the verson of the martian driver mentioned in the first post(martian-full-20061203.tar.gz).

    Back in feb. of 2007, I was able to get this driver working on the very first try in edgy. Then I killed the OS trying to setup Neverwinter Nights, oops. Unfortunately when I reinstalled ubuntu, I forgot to back up the instance of the driver I had, and had to download a new instance. I never got that driver to work right again on dapper, edgy, or fiesty. Then for some reason or another I decided to try the version released before 20061203, and voila....never had a problem with the older version.

    So if you're using 20061203, please, don't. Besides, there was a new release in august 2007, and it seems too work fine.

  8. #8
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2

    Connecting to internet via modem

    If anyone is still looking for a guide to installing this modem, here are the steps I took to set up my modem. I used wvdial for my dialer app. The only catch to this is that "martian_modem --daemon" has to be ran manually every time you reboot, and it has to be run as root. There is a way to make it so you don't have to do that, but at the end of june, I was just happy I could finally make it work again. (Note the issue I mentioned on my last post with the 20061203 driver version.) So I haven't looked in to the fancy stuff yet.

    Anyway....

    If you are using edgy or later, you might not need to do step 2 through 4, but for dapper and earlier this is a chicken and egg kind of thing, cause you need some type of internet connection for the first 4 steps.
    And theoretically, from what I've read, you're only required to update the headers and restricted modules. Since this is a perfect world, I just when ahead and updated everything in step 2.

    1. Use Ubuntu:Feisty - to guide you through adding repositories.

    2. Open synaptic, search for linux, and make sure that "linux-generic" (as for dapper it's just "linux") is marked for upgrade. Also make sure that the latest version of the headers, image, and restricted modules are marked in the same list.

    3. Wait for several hours....assuming you're connecting via internet connection sharing provided by another PC that can already dial out. Recommended time to do this,....just before bedtime.

    4. The next morning...before breakfast, reboot. After the system comes back up connect to the internet again. Open a console, and run
    sudo apt-get install build-essential linux-headers-`uname -r` wvdial
    then go have breakfest.
    (NOTE: I used a hyphen, not single quote, on both sides of uname-r)

    5. Now we can compile.
    sudo make
    sudo make install
    (If either of these commands return several errors, Make sure you've did you the installs mentioned in steps 2, 3, and 4.)

    I, of course , ran into issues with the automate and helper scripts, so to ensure that everything was done right I did all the following.
    6. sudo mknod --mode=0660 /dev/ttySM0 c 62 64



    7. sudo ln -s /dev/ttySM0 /dev/modem

    8. sudo modprobe martian_dev



    9. sudo gedit /etc/udev/rules.d/ltmodem.rules
    Add the following lines and save the file.

    # ltmodem KERNEL="ttyLTM0",

    SYMLINK="modem"

    Finally we're finished with the driver, so we'll go into dialing.
    10. sudo martian_modem --daemon
    (NOTE: Step 10 has to entered every time after a rebooting or logging in.)

    Create the initial configuration for wvdial.
    11. sudo wvdialconf /etc/wvdial.conf
    Hopefully in the output, at the end of at least some of the lines that start with ttySM0, there is an OK at the end of the line. If not, and you did run the command in step 10, then we've got issues, and you'll have to back track on your progress for any missed commands or errors.

    Configure wvdial for your ISP.
    12. sudo gedit /etc/wvdial.conf
    Remove the semicolon before PHONE=
    and put in the number you will dial after PHONE=. Dashes not required in the number. Do the same for the lines with USERNAME= and PASSWORD=, but of course provide your username and password instead of the phone number.
    Add the following lines:
    Carrier Check = no
    Auto Redial = yes
    Save and close the file.

    Now prepare for the moment of truth. DIAL!!!
    13. Type in wvdial and hit enter.
    Now you can watch the modem in action as it connects, hopefully. If you get permission errors when you run wvdial, you probably got caught by the catch. Try doing step 10 again, then wvdial.

    After you see the primary and secondary DNS numbers in the output, you should be on the information super highway and browsing. And another catch. Don't close this prompt or kill the command, it will cause the modem to disconnect. If you do see the DNS numbers and the output seems to have stoped, but you can't browse or make any contact to the internet, disable any other network interfaces that might be active, and redial. Especially if you havean RALink wireless card.

    Hope this amazing adventure helps and was worth a 4K download speed. I tried to fill in all pitfalls that I ran in to on my 4 month quest. I felt that may other gides left a lot of little details out. Especially for having to deal with dial up for the first time in anything but winblows.

    Goodluck,
    Any questions, advice, or shortcuts are welcome.

  9. #9
    Just Joined!
    Join Date
    Mar 2007
    Posts
    13
    Hey thanks! I am now using ADSL connection, but if I have time I will try to see if it works.

  10. #10
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1
    Please omit this step:
    6. sudo mknod --mode=0660 /dev/ttySM0 c 62 64

    Then all will be okay.
    You can also run martian_modem in debug mode to prove this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •