Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 24
You are a kind person! Ok, so building the rpm which looked the easiest won't work because some of the commands are outdated. The other method was 2. 'cd' to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52

    You are a kind person!

    Ok, so building the rpm which looked the easiest won't work because some of the commands are outdated. The other method was


    2. 'cd' to package directory:

    $ cd slmdm-2.7.14
    I have done this

    3. Review and edit (if need) 'Makefile'.

    Note: Probably you will want to correct in Makefile path to your
    local linux kernel header files:

    KERNEL_INCLUDES=/path/to/linux/include


    Another way is to pass command line the parameter while
    running 'make':

    $ make KERNEL_INCLUDES=/path/to/linux/include ...


    I think when I unzipped the tarball that bits of the directory went into different folders because I can find slmodemd in init.d and other places, but I also have the folder slmodemd-2.7.14 in my home folder where I copied it. I don't understand the KERNEL_INCLUDES path part. What does path/to/linux/include mean? I am not sure where my local linux kernel header files are. I understand the typing make KERNEL_INCLUDES=, but I don't know what the other bit should be.

    Note: If you do not have your Kernel Source files installed from
    your distribution of Linux. If not be sure to install them
    from them from your Linux distribution installation CDs or
    the driver will not install properly
    . I have my kernel source files installed, I checked using software manager under YAsT.

    4. Run 'make' command to compile package:

    $ make

    5. Install.


    # make install-usb

    if you are going to use USB modem.

    since I wasn't sure about the path part, I opened a terminal window in the slmdm-2.7.14 folder I made by right clicking in a blank part of the screen and from actions chose "open terminal window here". then typed make and make install-usb. I thought that would be the right path.

    some of the next bits I understand how to do, so am leaving them out

    Use 'slver -c' to see list of all supported countries and their
    codes (utility 'slver' may be found in package directory).

    do I just type slver -c?


    '/dev/ttySL0' with major number 212 and symbolic link '/dev/modem'.
    Use one of them as modem device for your dialing application.


    so THEN the link is created, and I don't need to be trying to initialize the /etc/init.d/slmodemd because it is truly installed?

    Thank you!

  2. #12
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    The /path/to/linux/include is the directory where the kernel include files reside.

    The make file will - among other things - compile the driver from source. For this purpose it needs the header files from this directory.

    This directory is often difficult to examine.

    It starts at least always with "/usr/src/". Then you might get something like "linux/linux-2.6.xxx" or so. Often you got three or more similar directory with strings like HUGEMEM or SMP in it.

    I actually don't know where to look up with confidence which directory is the right one. SMP is generally for boards with more than one processor.

    I generally look where a lot of header files reside. Header files have the ending *.h and are source files with plain ASCII text in it (C source files with English comments).
    Important is the combination "kernel/include" to look for because there are many other directories around also named "include" or "kernel".

    So, "/usr/src/linux-2.6.xxx/kernel/include" could be a right path, but in the middle can be much more directory names depending on your distro.

    If you run the make file with this path as argument, and you are root to let the make file perform changes in directories like /etc or /dev, then everything should run fine when no error messages appear.

    The make file should also setup "/etc/init.d/slmodemd" if your README file doesn't state otherwise.

    So, then you should be able to select slusb0 in your kppp program. (Fingers crossed )
    Bus Error: Passengers dumped. Hech gap yo'q.

  3. #13
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Ok, here is what I've found. In usr/src I have linux 2.6.16.13-4 AND usr/rc/linux a folder in both of them is called kernel. I reinstalled Suse at one point and when I boot it says I have a previous kernel. so I am thinking the right choice would be the usr/src/linux 2.6.16.13-4/kernel? Both have 63 document looking things that end with .h and both have 2 folders labeled irq and power. Both /usr/src/linux and linux ....folders appear to have the same files in them.

    So to follow the instructions correctly it would be to correct the makefile document in the slmdm 2.7.14 folder to read
    KERNEL_INCLUDES=/usr/src/linux2.6.16.13-4/kernel OR from the konsole window type make KERNEL_INCLUDES=/usr/src/linux2.6.16.13-4/kernel then I would type again make then type make install-usb

    then for my choices I would just put /dev/modem in the kppp? and make sure I have a modem showing up in my /dev file?
    I want to make sure I am doing this right, as i think I really messed things up by misunderstanding the directions. I think I've learned more about doing things correctly from you in the last couple days then I did in the last month banging my head against the wall and doing and trying things the wrong way.

    THANK YOU DILBERT!!

  4. #14
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Well, I messed up those directories and I hope you haven't started so far.

    The so much important directory combination is surely "/include/linux" as you stated in your posts and nothing else with "kernel" and the like.

    I asked also a colleague if there is a sure method to determine this directory and there is a symbolic link on presumably all distros.

    This is "/usr/include/linux".

    So, if you do a search on "/usr/src/" with the command find . -name "linux" and you get more than one directory because you got more than one /linux-2.6.xxx" directory, then "/usr/include/linux" is always the right choice.

    So, calling the make file with the argument like this make KERNEL_INCLUDES="/usr/include/linux" should do the job. The rest is as you guessed already.
    Bus Error: Passengers dumped. Hech gap yo'q.

  5. #15
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Thank you again for your time Dilbert!
    Well I thought with all the mucking about i had done trying to install drivers, I should just reinstall the Suse. So I re-installed the whole thing. This time when I installed it I noticed a choice for smartlink drivers that was a newer version than what came on the CD with the modem. So I clicked to install those. It seems like they installed, there are bits of slmodemd in different folders. I read the instructions about opening the .tar.gz But there WASN'T one! So I tried to do the cd slmdm -2.9.10 but there wasn't a folder like that. So I thought ok, I just need to click on the system/config in YAsT and under modem fill in the slusb0 in the box and start the slmodem daemon running. Then according the directions with this version you create a soft link from slusb0 to /dev/modem to keep KPPP happy. I did that, then restarted the /etc/init.d/slmodemd start the first time it did it, it loaded the drivers and I thought we were home free. But it still couldn't find the modem. So a post I read somewhere said might need to restart, so I did reboot. Now I can't get it to load the drivers, and I still don't have a /dev/modem file. the 56K modem IS showing up when I click on hardware info.
    It seems like the part where it is suppose to install on it's bits doesn't happen. The part that is suppose to take place during make and make install. But the folder you are suppose to go to isn't there and there are bits of it already in different folders. wvdial can't find a modem. Nor can KPPP, this is the result of my dmesg [drm] Initialized i915 1.4.0 20060119 on minor 0
    NET: Registered protocol family 17
    st: Version 20050830, fixed bufsize 32768, s/g segs 256
    lp: driver loaded but no devices found
    slusb: module not supported by Novell, setting U taint flag.
    slusb: module license 'Smart Link Ltd.' taints kernel.
    Symbol usb_register_driver is being used by a non-GPL module, which will not be allowed in the future
    Please see the file Documentation/feature-removal-schedule.txt in the kernel source tree for more details.
    Symbol usb_deregister is being used by a non-GPL module, which will not be allowed in the future
    Please see the file Documentation/feature-removal-schedule.txt in the kernel source tree for more details.
    ST7554 USB Modem.
    <6>slusb: slusb0 is found.
    usbcore: registered new driver ST7554 USB Modem
    TuxTop:/home/sheila # /etc/init.d/slmodemd start
    Starting SmartLink Modem driver: startproc: exit status of parent of /usr/sbin/slmodemd: 255

    Then it said FAILED.

    I'm so sorry Dilbert, I thought after I reinstalled and then found updated drivers for it that it would just hum. Especially since it was being installed by Suse's own program YAsT.
    Where is this going wrong?

  6. #16
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Well, after the re-install it looks a little more confusing to me than before.

    First of all, you could make a Web search or ask in the SuSe section if anyone ever has installed that modem with Suse.

    If you do an "lsusb" or an "/sbin/lsusb" you should see some output like this:

    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 004: ID 050d:258a Belkin Components
    Bus 001 Device 001: ID 0000:0000

    where instead of the cable from Belkin should pop up your modem.

    The first 4 hexadecimal number in front of the colon (here 050d) is the vendor ID, the second 4 digit hexadecimal number (here 258a) is the product ID. With those numbers you make a Web search to get mostly technical hits that might deal more with technical questions.
    Also it specifies exactly the same hardware that maybe is sold under different brand names.

    Having done this and hopefully having not got many hits with people saying it's unfeasible, let's try again things from bottom up.

    First, I don't understand why the drivers shouldn't be installed.

    On the "dmesg" output who is talking? Presumably a driver named "slusb".

    Check with "lsmod" or "/sbin/lsmod" all the drivers that are loaded. If there are many check the existence of slusb with "lmsod | grep slusb".

    I presume there is a binary "slusb.ko" of a driver loaded (in the lsmod output it's without ".ko" at the end) that names itself "ST7554 USB Modem". If the driver usbcore loads a driver it prints out simply a string that the author of the driver specified, in this case "ST7554 USB Modem".

    I suppose you should first check this driver and an existing device node /dev/slusb0.

    Here shortly again what your installation does. It's not to much.

    1.)
    Having a driver in binary form (i.e. a *.ko file) or as source file (an ASCII text *.c file) from CD. If it's a source file it has to be compiled (with the programm "make") but then you're sure it's fits into your kernel.

    2.)
    Loading this driver with "insmod -f driver_name.ko". If this fails there is no way around. You would have to get a new binary.

    3.)
    This driver should create a device node in the /dev dirrectory. With this device node the modem software (kppp e.g.) communicates with the modem hardware. So, if kppp sends a data packet, the kernel gets it with help of the driver on the device node and forwards it to the modem hardware.
    So, kppp writes to and reads from the file /dev/slusb0 (or linked to /devmodem) as it would be a standard file and doesn't care about anything else.

    4.)
    You have to tell kppp what device node it has to use.

    That's not much but if points 2 or 3 fail there is nothing to circumvent this.

    I guess you see now at least the cornerstones of what is going on. So you can check what the setup software has done.

    If you got stuck then ask again. No problem at all.
    Bus Error: Passengers dumped. Hech gap yo'q.

  7. #17
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52

    HUGE strides forward

    Ok, we are getting there Dilbert!
    Today I tried changing something using YAsT in the system/config part.
    Under hardware I changed the modem back to 1, it's default, then the line below the device was something about ALSA and in it's top part it was "yes" I set it to "no". I think ALSA has something to do with sound?
    then I did the modprobe slusb and then the line about linking and it DID create the link, so then I tried KPPP and it said MODEM READY and dialed! I can't hear it dial although my volume is set at max as you suggested, but it does say it connects. Then I get an error code 16 and says KPPP died. Here is the log

    ATZ
    OK
    ATM1L3
    OK
    ATDT9250005
    CONNECT 28800

    Apr 5 17:28:14 TuxTop pppd[5688]: Plugin passwordfd.so loaded.
    Apr 5 17:28:14 TuxTop pppd[5688]: pppd 2.4.3 started by sheila, uid 1000
    Apr 5 17:28:14 TuxTop pppd[5688]: using channel 10
    Apr 5 17:28:14 TuxTop pppd[5688]: Using interface ppp0
    Apr 5 17:28:14 TuxTop pppd[5688]: Connect: ppp0 <--> /dev/pts/2
    Apr 5 17:28:14 TuxTop pppd[5688]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x1043e59> <pcomp> <accomp>]
    Apr 5 17:28:16 TuxTop pppd[5688]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x1043e59> <pcomp> <accomp>]
    Apr 5 17:28:16 TuxTop pppd[5688]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x1043e59> <pcomp> <accomp>]
    Apr 5 17:28:16 TuxTop pppd[5688]: rcvd [LCP ConfReq id=0x7f <asyncmap 0xa0000> <auth chap MD5> <magic 0x2d1072b6> <pcomp> <accomp>]
    Apr 5 17:28:16 TuxTop pppd[5688]: sent [LCP ConfAck id=0x7f <asyncmap 0xa0000> <auth chap MD5> <magic 0x2d1072b6> <pcomp> <accomp>]
    Apr 5 17:28:16 TuxTop pppd[5688]: sent [LCP EchoReq id=0x0 magic=0x1043e59]
    Apr 5 17:28:17 TuxTop pppd[5688]: rcvd [CHAP Challenge id=0x43 <a7371d12a3a3aab46779512c01a8a5dc>, name = "sgbp-site"]
    Apr 5 17:28:17 TuxTop pppd[5688]: sent [CHAP Response id=0x43 <b43696f820897ce0f2c71f3d61225400>, name = "54391"]
    Apr 5 17:28:17 TuxTop pppd[5688]: rcvd [LCP EchoRep id=0x0 magic=0x2d1072b6]
    Apr 5 17:28:19 TuxTop pppd[5688]: rcvd [CHAP Failure id=0x43 "Authentication failure"]
    Apr 5 17:28:19 TuxTop pppd[5688]: CHAP authentication failed: Authentication failure
    Apr 5 17:28:19 TuxTop pppd[5688]: sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
    Apr 5 17:28:19 TuxTop pppd[5688]: rcvd [LCP TermReq id=0x80]
    Apr 5 17:28:19 TuxTop pppd[5688]: sent [LCP TermAck id=0x80]
    Apr 5 17:28:21 TuxTop pppd[5688]: sent [LCP TermReq id=0x3 "Failed to authenticate ourselves to peer"]
    Apr 5 17:28:23 TuxTop pppd[5688]: Connection terminated.
    Apr 5 17:28:23 TuxTop pppd[5688]: Modem hangup
    Apr 5 17:28:23 TuxTop pppd[5688]: Exit.

    since it says it is a chap problem, I tried to edit my chap file /etc/ppp/chap-secrets like I saw in another post and put

    # Secrets for authentication using CHAP
    # client server secret IP addresses
    54391 ruraltowns goofpup
    54391 * goofpup

    I added the above lines
    # OUTBOUND CONNECTIONS
    # Here you should add your PPP Login and PPP password to connect to your
    # provider via pap. The * means that the entry(login and passoword may be
    # used for ANY host you connect to.
    # Thus you do not have to worry about the foreign machine name. Just
    # replace password with your password.
    hostname * goofpup
    added the goofpup too

    # PREDIFINED CONNECTIONS
    # These are user and password entries for publically accessible call-by-call
    # Internet providers in Germany. If they confict with your config, remove them.
    # READ_IN_CALLBYCALL_SECRETS

    # INBOUND CONNECTIONS and so on and so forth

    The thing of it is, I know how to open PAP-Secrets and CHAP secrets in KWRITE to change lines and save them. But there is a LOT of writing in those files, and I tried just writing in
    number for computer to dial
    my user name
    my password
    like that in a blank spot, but that didn't seem to do it.
    Surely you don't just take out all that other writing and put your own stuff in?
    I'm not sure what or how to put in those two files, or if they are the only two files.
    I also don't understand why it isn't filled in when I set up KPPP and my dial up connection using YAsT?

    I also saw as I was trolling the forums for this problem that some have a etc/ppp/peers/provider folder and you should check in that. But I don't have that folder and am not sure why it wasn't created by KPPP or YAsT.

    I am thinking that all I need to do is edit those two files, and while I've seen examples of WHAT to write in them, I don't know where or how? Just any blank space? do you type something like phone 123-4567? or just 123-4567?
    I am afraid to go mucking about in these files since I think might make things a lot worse when they are close to working!

    We are almost there! Thank you so much Dilbert! You haven't steered me wrong yet!

  8. #18
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Quote Originally Posted by savvy_cowgirl
    I also don't understand why it isn't filled in when I set up KPPP and my dial up connection using YAsT?
    This is really strange. Even on my ancient FreeBSD 4.7 from 2002, I simply enter those credentials in kppp.

    I remember that setup with those ppp files, I reckon I did this in the year 2000 with a ppp program that you could call from the command line.

    That was actually not kppp, that was ppp or somewhat related, ppp_xxxx or so.
    Unfortunately, with all those examples you have to watch out carefully what version of ppp they are. I remember I struggled with this, too, and I hated it because of different examples without proper description what version it was for.

    I reckon there is definetly a problem with kppp writing into its own files. I don't know if there is anything in those kppp related files that you have changed?
    Maybe it's a permission problem. I believe you don't have to be root to add your user credentials but maybe there was an ownership problem during setup.

    What is also strange is that you try to connect with 28k speed. I'm pretty sure you're provider uses 56k. Well, the log says "CONNECT ...", but I would try it with 56k otherwise you would always have only half the speed. BTW you can test your kppp if it memorizes changes.

    To your last question: As far as I remember you edit in those ppp files only the bare number, the same with username and password and leave all the other stuff free as it was but I doubt actually that you are supposed to do this.

    Maybe ask this question in the SuSe section or I don't know if there is a different dialer program in concurrency to kppp that you could use as maybe there is something broken with kppp and difficult to repair by re-installing.

    kppp is actually only a nice GUI wrapper program that does all this ppp related file editing for you.
    Bus Error: Passengers dumped. Hech gap yo'q.

  9. #19
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Thank you Dilbert! You are a good teacher, and I am learning a lot about linux!

    Ok, thought about what you said, so I tried setting up wvdial, which is kind of easier to set up as they have fill in the blank style
    name=
    phone=
    password=
    sort of format. It too dialed, and then got the same note about the chap error.
    I want to use kppp, it is a nice program, and it seems wvdial has the same problem.
    This is my chap-secrets file where 12345 would be my user name and ruraltowns my ISP and goofpup my password. I don't know if I filled this out right, guess not since it doesn't work. I can't find any example of what a proper chap file under /etc/ppp should look like. I'm not as worried about the 28,800 connection speed as under windows right now I'm connected at 33,296 and it varies between 28 and 34,000 connection. On the windows side I have vista. Ok, this is chap-secrets what have I got wrong?

    # Secrets for authentication using CHAP
    # client server secret IP addresses
    12345 ruraltowns goofpup
    # OUTBOUND CONNECTIONS
    # Here you should add your PPP Login and PPP password to connect to your
    # provider via pap. The * means that the entry(login and passoword may be
    # used for ANY host you connect to.
    # Thus you do not have to worry about the foreign machine name. Just
    # replace password with your password.
    hostname * goofpup

    # PREDIFINED CONNECTIONS
    # These are user and password entries for publically accessible call-by-call
    # Internet providers in Germany. If they confict with your config, remove them.
    # READ_IN_CALLBYCALL_SECRETS

    # INBOUND CONNECTIONS
    #client hostname <password> 192.168.1.1
    12345 * goofpup

    I'm still pretty excited we have it dialing,
    Thanks again Dilbert!

  10. #20
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Texas, USA
    Posts
    107

    best modem

    Sorry if I'm shooting from the hip here. Have only glanced thru your posts and sounds like you're learning a lot about config files, however..... I noticed this is a USB external modem which is usually a winmodem although a quick google shows that this unit is supported using the cdc -acm usb module.

    Try lsmod as root and see if the cdc-acm USB module is listed.

    Also, do not be tempted to set modem speed too high - 115,000 and above in Kppp. It will load pages quickly, but eventually, downloads will stall the modem. I am currently achieving 56,000 kbps on a best data serial port modem by keeping the connect speed low. (This refers to teh connection between your processor and your modem, NOT between your modem and the 'net)

    Also, your ISP must be linux friendly, that is some providers like AOL require a special dialer for authentication. Coppernet has been very reliable, cheap and Linux friendly for me.


    Hope this helps
    good luck

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •