Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
Please help me, I've spent weeks googling & searching this and other forums. Part of this is I am very new to linux brought on by having purchased a computer ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52

    configure best date 56k modem problem?


    Please help me, I've spent weeks googling & searching this and other forums. Part of this is I am very new to linux brought on by having purchased a computer with Vista. I am trying to use SuSE 10.1 and think I will really like it if i can get on the net with it. I don't know if it is a configuration problem, installation problem, set up problem or what.
    I have dial up, it's all we have out here. Some day may get wireless available, but Embarq has said we will have broadband available the day before hell freezes over (though they were nicer about it).
    I bought a best data 56k external USB modem (my HP doesn't have a serial port) It came with drivers on a CD, with linux drivers & a readme file. I plugged in the modem and YaST does not detect it, but under hardware information it shows up under USB shows a 56k softmodem with a driver of ST7554 USB Modem and the drivers say active modprobe says yes. It shows to be a SGS Thomson Microelectronics 56K softmodem. If I look under File: /etc/sysconfig/slmodemd (using YAsT) in the Harware>modems section
    Possible Values: Any value
    Default Value: modem:1
    Service to Restart: slmodemd
    Description:

    Hardware(not modem) device for the slmodemd.

    slmodemd accesses hardware devices which are provided
    by the slamr and the slusb kernel modules. This congiuration
    setting determines which hardware device slmodemd should use.

    Use "modem" or "hw,y" in ALSA mode, x=card number, y=pcm number
    Use "slamr0" for SmartLink-compatible AC'97 Riser modem codecs
    Use "slusb0" for the SmartUSB56 from SmartLink(extermal USB modem)

    Note: After starting slmodemd, he will create a PTY (pseudo-termnal)
    and create a symlink called /dev/ttySL0 which points to this PTY.
    /dev/ttySL0 is the device used by applications.

    So in the box at the top where it says SLMODEMD_DEVICE I typed slusb0

    In KPPP I chose /dev/ttySL0 for my modem.

    I tried using this modprobe slamr
    /usr/sbin/slmodemd

    I found from another modem post and I got FATAL: Module slamr not found

    but my wheel with slmodemd IS in /usr/sbin I saw it!

    I tried to install the modem drivers following the instructions in read me. The easiest way looked like the rpm but the first command was to build and rpm & srpm from the tarball using # rpm -ta slmdm-2.7.14.tar.gz the "ta" command didn't work I googled and tried some alternative commands and short of it is a message about legacy syntax not being supported. The rest of it was stuff like # rpm -i /path/to/slmdm-2.X.X-Y.i386.rpm but since the first part didn't work, I didn't have any i386.rpms. So I unzipped the tarball using tar xvzf slmdm-2.7.14.tar.gz then tried to use the rpmbuild I read about during a google search, this didn't work either. So I looked at the other way. I copied the slmdm-2.7.14 file from CD to my hard drive. Then the instructions said to "you will want to correct in Makefile path to your
    local linux kernel header files:

    KERNEL_INCLUDES=/path/to/linux/include"
    I have no idea what this means or how to do it. But since it talked about path I opened a konsole window in the folder containing the files and typed "make" and make install. It didn't seem to work.

    I'm not really sure if this is even a problem since the modem shows in the hardware info that it has drivers and they are active.
    In the box at the top of the sys config using YAsT I replaced the modem:1 with the slusb0 from the choice list, didn't that create the link thing?

    Can someone please help me? I've googled and searched and I'm not even sure where I'm going wrong or what the problem is, I just know it isn't working.

  2. #2
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    I forgot to add, when I put in each of the choices for ports for kppp and "query modem" it is unable to open modem. Everything is plugged in.

  3. #3
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    I thought always with the kppp program the only thing you need is a serial port. The equivalent of a serial port would be your "/dev/ttySL0".

    As you got already a working driver that creates that device point, have you tried to run your modem just with that only?

    Maybe raising the modem volume and enabling debug output (both switches in kppp) you are getting to somewhere.

    Are you sure you need that rpm installation for your Suse distro? Maybe that rpm package on the CD is only for older kernels that don't have the modem driver with them.

    If you would really need that rpm stuff, then I would suggest that you ask the same question in the Suse section again. There are probably more people familiar with those rpm questions. To me it looks that in the case you would need the rpm package, installing it properly would solve your problem.
    Bus Error: Passengers dumped. Hech gap yo'q.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Quote Originally Posted by savvy_cowgirl
    I forgot to add, when I put in each of the choices for ports for kppp and "query modem" it is unable to open modem. Everything is plugged in.
    I got here only Linux boxes with LAN connection, but the kppp on the 2.6 Linux box shows me a bunch of device points, from /dev/modem, to /dev/ttyS0, to /dev/ttyUSB0, and many more.

    Did you all try them? Did you also try /dev/ttyS0 instead of /dev/ttySL0?

    You could try to run "dmesg". If you type that on a command line, it shows you the latest debug output from the kernel. If you connect the modem to the USB port and run "dmesg" after that, the modem driver prints out some info.

    Maybe it tells you what /dev/tty* device it's using. At least, the drivers of USB network devices tell you what Ethernet port they are using (e.g. eth2 or usb0) when the driver can use the hardware. Maybe the modem driver does the same.
    Bus Error: Passengers dumped. Hech gap yo'q.

  6. #5
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Thank you so much Dilbert for answering!

    Results of dmesg:
    There is a lot more, but it seemed this was the relevant bits:
    lp: driver loaded but no devices found
    slusb: module not supported by Novell, setting U taint flag.
    slusb: module license 'Smart Link Ltd.' taints kernel.
    Symbol usb_register_driver is being used by a non-GPL module, which will not be allowed in the future
    Please see the file Documentation/feature-removal-schedule.txt in the kernel source tree for more details.
    Symbol usb_deregister is being used by a non-GPL module, which will not be allowed in the future
    Please see the file Documentation/feature-removal-schedule.txt in the kernel source tree for more details.
    ST7554 USB Modem.
    <6>slusb: slusb0 is found.
    usbcore: registered new driver ST7554 USB Modem

    from the /usr/share/doc/packages/smartlink-softmodem/README:

    - some versions of 'kppp' may not work properly with devices named
    like '/dev/ttySL0'. To workaround this you may create symbolic link
    '/dev/modem' ( # ln -s /dev/ttySL0 /dev/modem ) and use this link
    as modem device with 'kppp'

    When trying to follow the smart-link softmodem readme file I get this :

    TuxTop:/home/sheila # modprobe slusb
    TuxTop:/home/sheila # /usr/sbin/slmodemd --country=USA /dev/slusb0
    error: mdm setup: cannot stat `/dev/slusb0': No such file or directory
    error: cannot setup device `/dev/slusb0'

    I have a internal software modem but when it I couldn't get it to work I was advised to get an external modem. As this lappy doesn't have a serial port all I could get was the USB modem.

    It sounded like from what the sys/config. from YAsT said I needed to start the slmodemd so that is what I was trying to do.
    Thing is, I DON'T know that I need to add those drivers from the CD, since SUSE seemed to have some, but since it didn't work, I thought maybe that was why. I've had Linux for less than a month, and it is all new to me, so trouble shooting is really hard. I don't know what is wrong or where to start so I search for anything that sounds similar and try it. But none of it has worked. I get messages, like the one above from dmesg and am not sure what they mean, or what to do about them.

    I didn't know if I should put this in SUsE or Newbies (cause I sure am) but finally decided on Networking as maybe this would be where others would look if they had this problem.
    Thanks again, I appreciate any and all the help I can get!

  7. #6
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Quote Originally Posted by savvy_cowgirl

    Results of dmesg:
    <6>slusb: slusb0 is found.
    usbcore: registered new driver ST7554 USB Modem
    Have you tried to only set the modem device in kppp to "slusb0" and then simply dial?

    Those latest lines from dmesg are written from the slusb driver.

    The driver says it would have set up "slusb0", so I guess this is already done. There is no second modprobe or insmod necessary. The error messages might result from the attempt to set up everything twice.

    At least the last lines saying "registered new driver ..." actually means that the driver is not only already loaded (this has been done where it says "tainted" and the like, not to worry about), but it also grabbed a device to work with.

    Well, those error or info messages from the kernel are not very obvious to a beginner.

    I would only double-check the existence of /dev/slusb0 and then select this under "modem" in kppp.

    I don't see anything that it should not be working already.

    Try to raise the volume volume in kppp and then simply dial.

    If it's still not working, ask again.
    Bus Error: Passengers dumped. Hech gap yo'q.

  8. #7
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Thank you again Dilbert!

    Ok, I've made a little list of what happens when each choice is picked.
    Modem volume is set to max.


    When I enter each choice using KPPP for modem location
    dev/modem –cant find
    ttyS1-S3----says the modem is busy (it's not, it's sitting right here beside me eyeing my coffee)
    ttyS4 ---unable to open modem
    ttyl0—ttyl3 unable to open modem
    usb/ttyACM0 –ACM3 Can't find modem am I sure I have it set up correct (um, well, no)
    usb/ttyUSB0 -USB3 Can't find & to please make sure I have it set up properly
    dev/tty/ACM0-- ACM3 Can't find & etc.
    dev/tty/USB0 –USB3--Can't find & etc.
    dev/usb/tts/0- usb/tts/3--Can't find & so on
    dev/rfcomm0-dev/rfcomm3—Can't find
    dev/ircomm0-dev/ircomm3—Can't find
    dev/ttySL0—dev/ttySL3—can't find
    dev/tty/SHSF0—3 same old, same old

    Then I tried to start the slmodem demon thing, it sounds like starting it is what makes the modem link
    TuxTop:/home/sheila # /etc/init.d/slmodemd
    *** Usage: slmodemd {start|stop|status|restart|condrestart}
    TuxTop:/home/sheila # /etc/init.d/slmodemd status
    Status of SmartLink Modem driver: unused
    TuxTop:/home/sheila # /etc/init.d/slmodemd start
    Starting SmartLink Modem driver: startproc: exit status of parent of /usr/sbin/slmodemd: 255
    failed


    I don't know if this tells anything or not, maybe the slmodemd isn't loading so it is making it work???

  9. #8
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Quote Originally Posted by savvy_cowgirl
    [B]
    To workaround this you may create symbolic link
    '/dev/modem' ( # ln -s /dev/ttySL0 /dev/modem ) and use this link
    as modem device with 'kppp'
    Well, I don't understand why "dmesg" is saying there is a /dev/slusb0 and this slmodemd program says there isn't.

    I think you need to look into your /dev directory and check if there is a slusb0 file or not.

    If it is there check if the necessary permissions are there with "ls -l slusb0". I'm not entirely sure what it has to be, but lots of dashes aren't a good sign. Check those permissions in your handbook or post them here.

    If you haven't got any slusb0 at all, that would be strange as "dmesg" was mentioning it. But in this case look what other devices are there that match your devices in the list from kppp, that ones you posted in your last post like /dev/modem.

    If you would find any of them, look at their permissions change those if necessary (ask if you have problems with this) and select them again in your kppp as you did already.

    If you would find one that ain't in that list from kppp, you could try this symbolic link like in one of your former posts, like "ln -s /dev/ttyXYZ /dev/modem", if ttyXYZ would be this strange newly found /dev device and you would select the /dev/modem" - wiyj confidence - from your kppp list.

    So, hope it's working now - or see you in a short time.
    Bus Error: Passengers dumped. Hech gap yo'q.

  10. #9
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Thank you Dilbert!

    I think you need to look into your /dev directory and check if there is a slusb0 file or not. There is NOT!! There is a USB folder in the BUS folder, but nothing in there looks like a modem connection. Under Dev I have folders of bus, disk, fd, input, mapper, net, pts, shm and snd and that's it!
    I think you are onto something here, I am wondering if my botched attempt at following the install instructions only got some of the files like slmodemd into the folders, but they aren't really there, or working right. I was able to open the tarball. But when I tried other parts, some of the instructions were outdated commands and the website of the manfg. doesn't have any updated linux directions. My google attempt to find the current way to install resulted in an error message that legacy syntax was not support.
    This is what the installation was suppose to do:
    It will install:
    - modem kernel modules slmdm.o (modem core), slfax.o (fax)
    into '/lib/modules/<kernel-version>/misc' directory
    (standard linux modules' directory).
    - hardware specific kernel module slamrmo.o (for AMR/CNR/PCI) or
    slusb.o (for USB) into '/lib/modules/<kernel-version>/misc'
    directory (standard linux modules' directory).
    - country settings data file 'country.dat' into directory '/etc'.

    Also it will:
    - create character tty device entry '/dev/ttySL0' with major
    number 212 and symbolic link 'dev/modem'.
    - config you '/etc/modules.conf' file in order to provide
    possibility for loading the modem modules into kernel on demand
    automatically by kmod, when you are going to use them.

    OK! ready and reporting for the next guidance!! Dilbert you are the coolest! dare I hope for light at the end of this tunnel?? Thank you for giving me instructions I understand what to do!

  11. #10
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    We are all learning.
    Bus Error: Passengers dumped. Hech gap yo'q.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •