Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    SAMBA Issue: "Network path was not found" on Windows XP SP2 Client

    SAMBA Issue: "Network path was not found" on Windows XP SP2 Client


    I've configured Samba on my Fedora Core 6 system to share a few group folders under /home/groups/.

    This /home partition is a separate mount that located on a SAN.

    Using the system-config-samba GUI I've created two samba shares that reflect the two folders under /home/groups that I want to share. They are /home/groups/group312 and /home/group/group320.

    I then told samba that the workgroup should be lfs1 and that the security settings should be:
    Authentication Mode = User
    Encrypt Passwords = Yes
    Guest Account = eeguser

    I then created a WIndows User that maps to eeguser as well.

    On the Linux system, the group folders are owned by 'eeguser' and the group ownership is also 'eeguser'

    Oddly, when I browse the lfs1 linux box from the network, I see the two group folders, and then I also see eeguser's /home directory (/home/eeguser).

    I can not access the contents of the two group folders, but I can access the contents of eeguser's home directory.

    When I attempt to browse into either group312 or group320 (the samba shares) I get an error on the Windows XP client:

    "Network path was not found."

    When I check the samba log for that machine, I get multiple instances of:

    [2007/04/02 13:36:40, 0] smbd/service.c:make_connection_snum(920)
    '/home/groups/tto502' does not exist or permission denied when connecting to [tto502] Error was Permission denied

    Oh, and I'm running the 3.0.24-3.fc6 version of samba.

    What in the world is the issue?



    [root@lfs1 samba]# testparm /etc/samba/smb.conf
    Load smb config files from /etc/samba/smb.conf
    Processing section "[homes]"
    Processing section "[printers]"
    Processing section "[group312]"
    Processing section "[group320]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions

    workgroup = LFS1
    server string = Lab File Server 1
    guest account = eeguser
    username map = /etc/samba/smbusers
    log file = /var/log/samba/%m.log
    max log size = 50
    dns proxy = No
    guest ok = Yes
    hosts allow = 192.168.14.,
    cups options = raw

    comment = Home Directories
    read only = No
    browseable = No

    comment = All Printers
    path = /usr/spool/samba
    printable = Yes
    browseable = No

    comment = Group 312 Share
    path = /home/groups/group312
    read only = No

    comment = Group 320 Share
    path = /home/groups/group320
    read only = No
    [root@lfs1 samba]#

  2. #2
    I am solving anything here but just trying to share some of my experiences
    1. Is iptables running in the samba machine ?
    from the XP box try
    telnet <the unix box> 139

    port 139 is samba port and if telnet is successful and you get a blank screen, then there is no problem with iptables. If telnet hangs, then you have to look into eihter adding 139 as trusted port or to stop iptables if the machine is in
    secure network.

  3. #3

    Thumbs up

    I was also having the same problem. I just stopped the "iptables" service and "samba" is now working fine.

    Thank you

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts