Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, all. I posted something a week ago about setting up USB modems, and it worked fine on Mandrake 9.1. But today I upgraded to Mandrake 10, which uses the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    jhk
    jhk is offline
    Just Joined!
    Join Date
    May 2004
    Posts
    7

    How to set up USB modems on kernal 2.6???


    Hello, all. I posted something a week ago about setting up USB modems, and it worked fine on Mandrake 9.1. But today I upgraded to Mandrake 10, which uses the new 2.6 kernel, and I love how fast it is. But it seems they removed the CDCEther module! I've done some google searches on how to set up a modem in kernal 2.6, but couldn't find anything.

    I've read something about CDCEther being merged into usbnet, but usbnet by itself certainly doesn't work.

    Any ideas? My modem is a Scientiific Atlanta Webstar 2100.

    -JHK

  2. #2
    jhk
    jhk is offline
    Just Joined!
    Join Date
    May 2004
    Posts
    7
    Since I couldn't find anything else on the web, I tried typing in random combinations.

    modprobe usbnet eth

    works. Duh! Hint to all Linux newbies like me who have this same problem.

    -JHK

  3. #3
    jhk
    jhk is offline
    Just Joined!
    Join Date
    May 2004
    Posts
    7
    And then suddenly Linux refuses to recognize the modem again while I was browsing. Anybody know what happened? modprobe usbnet eth doesn't work now.

    -JHK

  4. #4
    jhk
    jhk is offline
    Just Joined!
    Join Date
    May 2004
    Posts
    7
    I know I'm making myself a pain here... I'm sorry! But I want internet on my Linux box...

    I checked dmesg, and it says that there was an error scanning the usb port my modem is on- error 75, or the 'babble' error. I understand that this is caused by an overload of information from the device, but I'm not sure how you fix it... the modem worked without a hitch on Mandrake 9.2.

    Any ideas?

    -JHK

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •