Find the answer to your Linux question:
Results 1 to 2 of 2
I am running a dual boot system (slackware 9.1 & win xp) I have errors when connecting to a FTP server from the linux side only. My connection from windows ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    FTP connection


    I am running a dual boot system (slackware 9.1 & win xp) I have errors when connecting to a FTP server from the linux side only. My connection from windows is fine. I have tried many different ftp clients, with no success.
    I can connect, log in, change directories but not list, get or put any files. When I try to list get or put I get the same error message :

    500 Illegal PORT command
    ftp: bind: Address already in use

    I was thinking it was a firewall problem, but I have tried allowing all ports from all destinations and that didn't help. The one thing I do know is that the ftp server doesn't accept passive connections. I am at a loss here I would love to get this resolved so I can finally remove windows all together from this machine.

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Have you tried to enable/diable passive mode? My server says it doesn't allow passive connections either, but I enabled anyway and it started working. Go figure?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •