New here guys, thanks for any help! Trying to get as many suggestions as possible.

Ok, after much hard work and a LOT of messing around I finally nearly have this working.

Using Kubuntu, I've figured out that if I completely disable my wireless and manually set up wired connection, it will easily ping the 'dozeXP laptop and they will chatter as long as the Gateway on the Kubuntu box is set to 192.168.0.1.

However while it is like this, with the wireless enabled too, the wireless will NOT connect to the internet. But, when I change the gateway to 192.168.0.2 (on the wired connection), I can connect to the internet, but no longer ping the laptop box or communicate with it!! So I can have both of these interfaces active at the same time, I'm just misconfiguring something.


Laptop <--- Kubby Box <---- Wireless Internet Magic (Router)

Other things:

Wireless settings (eth1)

DHCP (No encryption of any type)
IP: 192.168.0.2
GW: 192.168.0.1 (the ip address of the router, of course)

Current wired settings (eth0)

IP (static) 192.168.0.10
Netmask: 255.255.255.0
GW: 192.168.0.2 (so I can post this...)

'Doze box

IP (I assigned, manual settings): 192.168.0.4
Netmask: 255.255.255.0
Default GW: 192.168.0.10
Preferred DNS: 192.168.0.1