Find the answer to your Linux question:
Results 1 to 2 of 2
hi I cannot login into ssh due to the following error: Code: storage> ssh localhost Permission denied (publickey,password,keyboard-interactive). my system: Code: storage> uname -a Linux storage 2.4.22-uc0 #458 Tue Apr ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    cc
    cc is offline
    Linux Newbie
    Join Date
    Jun 2004
    Posts
    120

    Permission denied (publickey,password,keyboard-interactive)


    hi

    I cannot login into ssh due to the following error:
    Code:
    storage> ssh localhost
    Permission denied (publickey,password,keyboard-interactive).

    my system:
    Code:
    storage> uname -a
    Linux storage 2.4.22-uc0 #458 Tue Apr 3 01:09:49 CST 2007 ppc unknown
    Code:
    storage> ssh -v
    OpenSSH_4.2p1, OpenSSL 0.9.7e 25 Oct 2004
    Code:
    storage> ls -la /etc/ssh
    drwxr-xr-x 2 root root 1024 May 28 03:23 .
    drwxr-xr-x 8 root root 2048 May 28 03:13 ..
    -rw------- 1 root root 1192 May 28 03:12 ssh_host_dsa_key
    -rw-r--r-- 1 root root 1114 May 28 03:12 ssh_host_dsa_key.pub
    -rw------- 1 root root 975 May 28 03:03 ssh_host_key
    -rw-r--r-- 1 root root 639 May 28 03:03 ssh_host_key.pub
    -rw------- 1 root root 1675 May 28 03:05 ssh_host_rsa_key
    -rw-r--r-- 1 root root 394 May 28 03:05 ssh_host_rsa_key.pub
    -rw-r--r-- 1 root root 2974 May 28 03:23 sshd_config
    -rw-r--r-- 1 root root 2961 May 28 03:27 sshd_config_org
    -rw-r--r-- 1 root root 2977 May 28 03:23 sshd_config_save

    my sshd configuration:
    Code:
    # vi etc/ssh/sshd_config
    
    # $OpenBSD: sshd_config,v 1.72 2005/07/25 11:59:40 markus Exp $
    
    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.
    
    # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin
    
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.
    
    Port 22
    Protocol 2,1
    #AddressFamily any
    ListenAddress 0.0.0.0
    #ListenAddress ::
    
    # HostKey for protocol version 1
    HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key
    
    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768
    
    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO
    
    # Authentication:
    
    #LoginGraceTime 2m
    PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6
    
    RSAAuthentication yes
    PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys
    
    #now ssh is only used by rsync ==> auth by passwd file of rsync server
    #AuthPassFile /etc/rsyncd.secrets
    
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    RhostsRSAAuthentication no
    # similar for protocol version 2
    HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    IgnoreRhosts yes
    
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication no
    PermitEmptyPasswords no
    
    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
    
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
    
    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no
    Compression yes
    
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    
    DenyUsers admin
    
    # no default banner path
    #Banner /some/path
    
    # override default of no subsystems
    Subsystem sftp /usr/libexec/sftp-server

    I tried to remove /root/.ssh/known_hosts
    and regenerate all keys:
    Code:
    ssh-keygen -t rsa1 -f /etc/ssh/ssh_host_key -N ''
    ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N ''
    ssh-keygen -t dsa -f /etc/ssh/ssh_host_dsa_key -N ''
    but still doesn't work !

    knows someone howto solve this problem ?

  2. #2
    cc
    cc is offline
    Linux Newbie
    Join Date
    Jun 2004
    Posts
    120
    I've installed openssh again:

    # ipkg install openssh

    and now it seems to work.

    thanks anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •