Right I'm running ubuntu server edition 7.04

I have recently configured squid as a cache server to help speed up the net but the problem is that we are using 2 broadband connections. One for apache ventrilo, mail, website etc and the other was for general use.

But I Don't know how to tell squid to use one and apache to use the other.

I have tried adding another nic and setting a different default gateway for each then telling apache to listen on one and squid to do its thing on the other but no luck.

I'm trying to get my head round the linux route command as its the first time I have had to do anything other than set a default gateway with it.

Any help much appreciated.

-Mupet