Hi,

I have an ISA 3com Etherlink III installed on a Compaq Presario 5222 running ubuntu edgy server edition. I have loaded the driver and fixed the IRQ issues it had, but it won't connect to my home network. To configure the network, I edit /etc/network/interfaces. I have tried both dhcp and static methods of connecting, but when I try to ping the router, I get
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.206 icmp_seq=1 Destination Host Unreachable
From 192.168.1.206 icmp_seq=2 Destination Host Unreachable
From 192.168.1.206 icmp_seq=3 Destination Host Unreachable
From 192.168.1.206 icmp_seq=4 Destination Host Unreachable
From 192.168.1.206 icmp_seq=5 Destination Host Unreachable
From 192.168.1.206 icmp_seq=6 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
9 packets transmitted, 0 received, +6 errors, 100% packet loss, time 8026ms
, pipe 3
This is my /etc/network/interfaces
# The loopback network interface
auto lo eth0
iface lo inet loopback

#iface eth0 inet dhcp (not in use)

iface eth0 inet static
pre-up modprobe 3c509 irq=9,13
address 192.168.1.206
netmask 255.255.255.0
gateway 192.168.1.1
broadcast 192.168.1.255
post-down rmmod 3c509
I think this might be a routing problem because when I run route, I get

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.1.1 255.255.255.0 UG 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
and 192.168.1.0 doesn't exist on my network and route del won't get rid of it. However, I am not sure.

What is the problem, and how can I fix it. Thanks.