Find the answer to your Linux question:
Results 1 to 4 of 4
I have a computer that I am using as a samba server. It is running kubuntu 6.10. It did not have samba on it so I just used apt-get install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    4

    cannot connect to samba server from windows xp home


    I have a computer that I am using as a samba server. It is running kubuntu 6.10. It did not have samba on it so I just used apt-get install samba to install samba so my samba is probably the latest version. I have set up one share. I can access this share form my computer running Debian however I also want to access this share form my computer running windows xp home edition. All the computers on my network can see all of the other computer on my network however if I try to connect to my Kubuntu computer from xp I get an annoying little popup saying "\\THENAMEOFTHESERVERthenameoftheserver is not accessable. you might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions." This is obviously annoying.

    this is the entry for the share in my smb.conf file:

    [myshare]
    comment = files
    path = /home/jcsokolow
    public = yes
    writable = yes
    printable = no
    create mask =0765
    guest ok = yes
    guest only = yes


    with this configuration I can read write and view all the stuff in this share from my Debian computer just fine. But I need the windows computer to be able to do that too.

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Posts
    1

    samba and windwos XP home

    I kind of newbie and iam having the same problem..I install samba in my linux machine. I can see from my wondows XP home the computer in my windows neighboorhood..I know I cna no create a domain with windows Xp home and samba..but I think i can create w workgroup and do some files an print share...at this poing i can ping both computers by name and IP address..I mean I can ping from my windwos XP home to unix and from Unix to XP home...I can see the share from the windis XP home but it said hat i have no permission to read the samba share...I create a password samba and unix password wxactly the same that in my windows xp machine..because I was thinking that was a password problem..but i recieved the same problem...any input will be greatly appreciatted...thanks in advance
    Fernando Parrado

  3. #3
    Linux Newbie
    Join Date
    May 2007
    Location
    Maldives
    Posts
    126
    hi,
    in samba config file did you specify the windows work group in global section. by default in windows, it will be workgroup, and also you have to type yes in the wins support.In my distro, the config file is located at etc/samba.

    If you have configured it correctly, but cannot access, there might be some other problem. In fedora, (in my first attempt ever) i configured everything correctly. but the same error as yours kept popping up. it was driving me crazy, but once i disabled the linux firewall and Selinux, everything was fine.. you can try this aswel.

    Nabaachy

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2007
    Posts
    20
    There are several reasons this might happen.
    I suggest installing SWAT the front-end for Samba and you can configure everything much easier( share/rights etc); also you have to make linux users and then samba users for it work.

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •