Find the answer to your Linux question:
Results 1 to 5 of 5

Thread: Lost connection

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Lost connection

    Hi all,

    i've got some problem with my lfs system. I have one ssh server and httpd which are running on my system and i lost a lot of connections.

    For example, i have some ssh connection. One of them fails while the other work well. Sometimes, i lost all connection, i can't reach the web interface of my server. I wait a few minutes and it works again.

    Here is a netstat result when i lost connection:

    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 ESTABLISHED
    tcp 0 0 ESTABLISHED
    tcp 0 156 ESTABLISHED
    tcp 0 1008 ESTABLISHED
    tcp 0 0 ESTABLISHED
    tcp 0 192 ESTABLISHED
    You can see i have tried ssh connection on localhost and it is the same thing. The Send-Q column is very strang in my opinion.

    I use linux My network interfaces are one Intel e100 and 2 3COM 3C905CX-TX-M PCI 32 and it's the same thing for all network interfaces.

    Where can i found what my problem is ? I don't really know the /proc/sys/net filsesystem but i think i have some option to change in order to resolve my problem.

    Thanks a lot for your help.

  2. #2
    I have use ethereal in order to see what happen when i lost connection. It seems there are problems in ACK values.

    Transmission Control Protocol, Src Port: 222 (222), Dst Port: 1868 (1868 ), Seq: 612, Ack: 104, Len: 0
    Transmission Control Protocol, Src Port: 1868 (1868 ), Dst Port: 222 (222), Seq: 104, Ack: 0, Len: 52
    Transmission Control Protocol, Src Port: 222 (222), Dst Port: 1868 (1868 ), Seq: 612, Ack: 156, Len: 0
    i d'ont realy understand why the ack value is 0 ?
    can you help me please ?

  3. #3
    Hi all,

    i have some news about my problem!
    it seems that it's my kernel which causes problems. I have tried with Linux-2.6/19.7 and it works now. My problem is now to determine where does the problem come from...

    I will try to change my kernel options. And perhaps try without any patch on kernel (actually i have patched IMQ, route and layer7).

    If you have any ideas... Perhaps i should post on a linux kernel topic.

  4. $spacer_open
  5. #4

    ssh connections seems to stop but...

    I have the same problem with kernel ssh seems to stop working randomly but it still work and send commands to my server. The terminal freeze after I insert the imq module. If i remove a short period after the terminal unfreeze and the ssh connection continue to work in the terminal that freeze. My solutions are to use the real interfaces to shape trafic or to use another kernel.

    Can somone explain what really trigger this behaiviour in the kernel?

  6. #5

    i have solved my problem by compiling all my network devices drivers as modules...

    Hopes it will help you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts