Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 34
Well first off, I dont have a sysconfig folder in /etc/, so therefore no desktop file to edit...(should I create one?) No, if you don't have one, that's not the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User
    Join Date
    Jul 2004
    Posts
    256

    Well first off, I dont have a sysconfig folder in /etc/, so therefore no desktop file to edit...(should I create one?)
    No, if you don't have one, that's not the file to change to fix your problem.

    I'm using slackware 10 also, but not the graphical login. If you use text login, theres 2 ways to change your WM:

    1) edit ~/.xinitrc
    2) run "xwmconfig" wich will replace your ~/.xinitrc for you (dont do this if you have programs to run in your .xinitrc)

    Do a "$ ls -a" in your home directory, there may be some file to edit for your graphical login, maybe .xsession.

    Did you edit any files to use a graphical login, or just edited the default runlevel?
    --monkey

  2. #12
    Just Joined!
    Join Date
    Jun 2004
    Posts
    44
    No I didnt edit any files other than inittab to change the runlevel to 4.

    So good news and bad news now. Good news is that i found some configuration files inside my home directory, and i was able to edit them. Bad news is it did nothing lol.

    Anybody know which file contains the last session data or something? maybe its just not writing the session to that file so that when i select last it always thinks its gnome.

  3. #13
    Just Joined!
    Join Date
    May 2004
    Posts
    34
    Quote Originally Posted by SlackerWannabe
    No I didnt edit any files other than inittab to change the runlevel to 4.

    So good news and bad news now. Good news is that i found some configuration files inside my home directory, and i was able to edit them. Bad news is it did nothing lol.

    Anybody know which file contains the last session data or something? maybe its just not writing the session to that file so that when i select last it always thinks its gnome.
    Linux has a convoluted way of determining your window manager. If you 'did' have a /etc/sysconfig/desktop file you could change your default window manager and your default login manager. You should have a file like this but its different from distro to distro. I guess you have some hunting todo Do you at least have an /etc/prefdm or /etc/X11/prefdm? ** prefdm is short for preferred display manager **

    Also, I have an .Xclients-default in my home dir and looks like this:

    # Created by Red Hat Desktop Switcher
    exec startkde

    I can chage it by hand to start gnome or run the desktop switcher (which is distro specific to redhat, but I'm sure there are equivalents)

    -Kauai

  4. #14
    Just Joined!
    Join Date
    Jun 2004
    Posts
    44
    Unfortunately I do not have the files you mentioned...but like I said, I have a feeling it has something to do with wherever the 'last' session is saved...Not with my default window manager...because after all, last means last and not default right? Although I have no clue where to look for this configuration

    Is there maybe some sort of diagnostic I could do to check what it does when loading up the desktop manager and environment? maybe its encountering some error and defaulting to gnome?

  5. #15
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    Or you could just set the default runlevel to 3, then "startx" will read your ~/.xinitrc,

    If you must have a graphical login, are you using xdm?
    --monkey

  6. #16
    Just Joined!
    Join Date
    Jun 2004
    Posts
    44
    I prefer the graphical login (although it isn't necessary) and it also really bugs me that I can't fix this. There must be a way.

    I am using gnome's session manager.

  7. #17
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,226

    Gnome loads up instead of KDE

    As far as I can remember .xinitrc only works when you go into your GUI via startx, not when you log on graphically using something like kdm or gdm. Have you got a new file in your home directory called something like .Xclients or .Xclients-default? If so and if it ends with "exec gnome-session, try changing this to "exec startkde"
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  8. #18
    Just Joined!
    Join Date
    Jun 2004
    Posts
    44
    No I don't have a folder or file like that in my home directory. I think this has to do only with gnome session manager, and not with xinitrc type scripts, because I don't have the same problems with KDE's session manager.

  9. #19
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    Open a terminal.
    Code:
    su
    Password:
    mcedit /etc/rc.d/rc.4
    Look for:
    Code:
    # Try to use GNOME's gdm session manager:
    if [ -x /usr/bin/gdm ]; then
      exec /usr/bin/gdm -nodaemon
    fi
    Comment it out. It should look like:
    Code:
    # Try to use GNOME's gdm session manager:
    #if [ -x /usr/bin/gdm ]; then
    #  exec /usr/bin/gdm -nodaemon
    #fi
    F2 to save. F10 to exit.
    Code:
    mcedit /etc/inittab
    Look for
    Code:
    # Default runlevel. (Do not set to 0 or 6)
    id:3:initdefault:
    Make it look like
    Code:
    # Default runlevel. (Do not set to 0 or 6)
    id:4:initdefault:
    F2 to save. F10 to exit.
    That will boot the system automatically to KDM.
    To change the prefered DE/WM, Slackware uses xwmconfig. From a console, log in to your users account and
    Code:
    xwmconfig
    and select your preference.
    OH NOOOOO!!!!!! You did it the way I said?

  10. #20
    Just Joined!
    Join Date
    Jun 2004
    Posts
    44
    I think you may have misunderstood what I am asking. I am not trying to change the session manager. I am trying to change the desktop environment that loads up after I log in from the gnome session manager. The problem results from me selecting the "Last" option (which is selected by default), as it is supposed to load up the environment that was last used, but instead it just loads up gnome's desktop environment.

    I want to keep Gnome's session manager, but I wan't to figure out why the session manager isn't keeping track of what desktop environment I used last.

    And even if I use KDE's session manager, I don't have the option of choosing XFCE4. Plus I prefer the look of Gnome's session manager.

    Im trying to find where Gnome's session manager stores the data about the previous desktop environment that was loaded. If I can find that, then I can probably figure out how to fix it.

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •