Find the answer to your Linux question:
Results 1 to 7 of 7
I have all my mp3's on my second hard drive on a ntfs partition. However, when I mount a partition, I can't seem to access it without being root. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    11

    How to access mounted harddrives without being root?


    I have all my mp3's on my second hard drive on a ntfs partition. However, when I mount a partition, I can't seem to access it without being root. I would like to be able to add my mp3 folder to my xmms playlist, but this only works if i run xmms as root. Any way around this?

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Does your /etc/fstab have the option of user for the mount point?
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    11
    My /etc/fstab doesn't have an entry for the second hard drive at all. Currently the second hard drive does not mount automatically at boot. I have to type:

    mount /dev/hdb1 /mnt/hdb1

    I tried editing the /etc/fstab file by adding the line:

    /dev/hdb1 /mnt/hdb1 ntfs user 0 0

    but when i rebooted it said "updating /etc/fstab" and the line i adding was gone.

    Note: hdb1 is a dynamic disk.

  4. #4
    Just Joined!
    Join Date
    Mar 2004
    Posts
    11
    Hmmm, the line i added to /etc/fstab is there again, so maybe i just imagined that it was gone...strange.

    Anyway, now when i type 'mount' with no parameters, the following line is in my list of mounted drives:

    /dev/hdb1 on /mnt/hdb1 type ntfs (rw,noexec,nosuid,nodev)

    and, as root, i can access it without having to manually mount it, so i guess it is automatically mounting at boot. However, if i try to access it while not root i get:

    [louis@localhost louis]$ cd /mnt/hdb1
    bash: cd: /mnt/hdb1: Permission denied

    Here is my /etc/fstab:

    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    /dev/hda5 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/hdb1 /mnt/hdb1 ntfs user 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

  5. #5
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Maybe try replacing the "user" in
    Code:
    /dev/hdb1 /mnt/hdb1 ntfs user 0 0
    with "users". This should give all users in the group "users" the right to unmount the drive, and if they have that then maybe they can access it too... it's worth a try.
    Situations arise because of the weather,
    And no kinds of love are better than others.

  6. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    11
    Ok the problem has been solved. I needed to add the umask=0000 option in the /etc/fstab entry. The user option only gives users the permission to mount/umount the drive, but doesn't effect the permissions. I think chmod doesn't work because linux doesn't natively support ntfs permissions.

  7. #7
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by Sureshot324
    I think chmod doesn't work because linux doesn't natively support ntfs permissions.
    That is correct. And you can add the option 'noauto' in your fstab if you don't want it mounted at boot.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •