Find the answer to your Linux question:
Results 1 to 10 of 10
Hi there! I'm having some trouble using parted1.6.10 on redhat 9.0, I wanted to make a new partition on my hd, so i decided to use parted. This is how ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    /home/
    Posts
    9

    How can I make a filesystem on some free HD space?


    Hi there! I'm having some trouble using parted1.6.10 on redhat 9.0, I wanted to make a new partition on my hd, so i decided to use parted. This is how my hd looks like after shrinking my fat32 partition (using parted):

    Code:
    (parted) print
    Disk geometry for /dev/hda: 0.000-76319.085 megabytes
    Disk label type: msdos
    Minor    Start       End     Type      Filesystem  Flags
    1          0.031  35997.209  primary   fat32       boot, lba
    2      41346.980  41448.955  primary   ext3
    3      41448.955  75296.843  primary   ext3
    4      75296.843  76316.594  extended              lba
    5      75296.874  76316.594  logical   linux-swap
    (parted)
    My old fat32 partition started on 0.031 and it ended at 41346.980, so i shrinked it to have some space for an ext2 filesystem, but now this is what I get when I use mkpartfs:

    Code:
    (parted) mkpartfs logical ext2 35997.209 41346.980
    Warning: Unable to align partition properly.  This probably means that another
    partitioning tool generated an incorrect partition table, because it didn't havethe correct BIOS geometry.  It is safe to ignore,but ignoring may cause
    (fixable) problems with some boot loaders.
    Ignore/Cancel? Ignore
    Error: Unable to satisfy all constraints on the partition.
    (parted) mkpartfs logical ext2 35998 41345
    Error: Unable to satisfy all constraints on the partition.
    (parted)
    Well, I hope somebody can help me out, because I'm not even sure if I used parted correctly to shrink my partition(but it seems to), I don't even know if the PART-TYPE argument on mkpartfs is correct . Please tell me if you need more info about the problem or if there's another program you suggest me to use.

    Thanks!
    F1D3L

    :rock: LINUX :rock:

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    37
    Ok... First of all I have to say i've never heard of mkpartfs i'll have to look into it... But I would suggest using a diff program so i can help ya out better.

    Check to see if you have cfdisk or fdisk... if you have cfdisk then use that because it's alot nicer to work with if your kinda new to linux and partitioning.

    Also to find out if you have either of these programs, just start typing the name of the program then press tab and linux should auto complete the name for you... that's if you have it.. or it will just print out a bunch of programs that start with what you have typed: example...

    cf and then tab button --> will print out all programs that start with 'cf'.

    And make sure you are root when you are looking for these programs because these programs are only for root use.

    So... to save some time... lets say you do have cfdisk... now what you need to do is find out what device your fat32 drive is... by the looks of it, it looks like you have one hard drive which is /dev/hda and you are dual booting with it...

    So one of my questions is... are you looking to just delete the windows partition and make a new linux partition on it? or are you trying to resize your windows partition?

    What ever you are trying to do post back.. but if you want to use cfdisk, you would do as follows:

    cfdisk /dev/hda

    You will then enter the program and all your partitions will be listed, then from there you can delete and create partitions... or whatever you want to do.

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    /home/
    Posts
    9
    Thanks for helping! I don't have cfdisk on my system, and I'm not pretty sure where to get it. I looked for it at http://freshmeat.net/, and it seems to be included in the util-linux, I hope this is the right program, if not please tell me where to find it (I actually downloaded http://freshmeat.net/redir/util-linu...x-2.12a.tar.gz).

    I'll try to install it, and make it work.

    Yes, I only have one hard drive which is /dev/hda, now, what I'm trying to do is to create an ext2 filesystem on the free space on my hard drive (I have already resized my fat partition, and I don't want to delete it). The free space on my hd goes from MB 35997.209 to MB 41346.980.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2004
    Posts
    37
    Ok.... yea if you can get cfdisk installed that would be rockin, but I just wanna make sure did you look for cfdisk when you were root? because only root can use that program. (I"m sure you already know this but it's always a good thing to make sure.). Once you get cfdisk installed, you should be set.. because you can create the partition you want and make a filesystem on it with cfdisk. And yea I believe it's in the linux-util package you have there... i'm not sure on what dependencies are required, hopefully not too many, but shout back lemme know whats up.

    tar -xvzf linux-util.tar.gz
    cd linux-util
    ./configure
    make
    make install

    Should be all you need to do to install the linux utilities, peace.

  6. #5
    Just Joined!
    Join Date
    Jul 2004
    Location
    /home/
    Posts
    9
    Welll... yes, I looked for cfdisk being root, but I didn't find it (as you told me I just typed cf and then the tab button, but the computer just beeped after each time I pressed the tab button, I actually typed cfdisk ant then the Enter button and nothing happened so I supposed that meant it wasn't installed).

    I've already installed it and it seems to work . When I run the program this is what I get:
    Code:
                                      cfdisk 2.12a
                                                                                    
                                  Disk Drive: /dev/hda
                            Size: 80026361856 bytes, 80.0 GB
                  Heads: 255   Sectors per Track: 63   Cylinders: 9729
                                                                                    
        Name        Flags      Part Type  FS Type          [Label]        Size (MB)
     ------------------------------------------------------------------------------
        hda1        Boot        Primary   W95 FAT32 (LBA)                  37745.81
                                          Unusable                          5609.65
        hda2                    Primary   Linux ext3       [/boot]           106.93
        hda3                    Primary   Linux ext3       [/]             35492.09
        hda5                    Logical   Linux swap                        1069.29
    And these are the options when the Unusable space is highlighted:
    Code:
         [  Help  ]  [ Print  ]  [  Quit  ]  [ Units  ]  [ Write  ]
                                                                                    
                                                                                    
                Write partition table to disk (this might destroy data)
    Sorry about my ignorance, but I don't know what to do now . Does that Unusable label really mean that I won't be able to create a partition on that free space?

  7. #6
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    I've never actualy gotten a partition that said unusable. But I would suggest that you highlight it and select it,try to format it, but there might be a problem with the location of your freespace, since its in the middle of your drive, i always resize from the end. but you could move all your partitions up and then see if the space is usable. (just select the partition and select the move option)
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  8. #7
    Just Joined!
    Join Date
    Jul 2004
    Posts
    37
    hmm.. that's odd how you can't delete the unusable partition...

    I'd suggest tryin fdisk and see what that comes up with, you've gotta be able to erase the partition and then make one with that free space.

    try this:

    fdisk /dev/hda

    then press 'h' for help and the menu with all the options will pop up

    tell me if it still says unusable space still with fdisk..

  9. #8
    Just Joined!
    Join Date
    Jul 2004
    Location
    /home/
    Posts
    9
    Ok... I tried fdisk, and this is what I get:
    Code:
    Command (m for help): p
     
    Disk /dev/hda: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
     
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1   *           1        4589    36861111    c  W95 FAT32 (LBA)
    /dev/hda2            5272        5284      104422+  83  Linux
    /dev/hda3            5285        9599    34660237+  83  Linux
    /dev/hda4            9600        9729     1044225    f  W95 Ext'd (LBA)
    /dev/hda5            9600        9729     1044193+  82  Linux swap
     
    Command (m for help):
    I guess there isn't a partition on that free space, right? Well, anyways, I've never used fdisk before, so I'm not pretty sure on what to do next, I tried 'n', but I got the following message: 'No free sectors available'. I don't even know if I tried the right command.

    One more question, if I get to create the filesystem I wanted, do I need to change any files on my system (like fstab or something)? Or will the creation of this filesystem affect the bootup process?

  10. #9
    Just Joined!
    Join Date
    Jul 2004
    Posts
    37
    Yea, you need to delete one of your partitions in order to make a new partition... so i'm not sure what you want to keep or don't care about. But once you got that figured out, delete the partition you don't care about then create a new one with 'n'.

    It will then ask you what sectors you want to add a partition too, and the default will be all available sectors which is what you will probably choose, so then you would just press enter.

    Then you can pick what type of filesystem you would like to have such as ext2, ext3, or what ever, I believe ext3 is either number 82 or 83, but I think there is an option to view what all filesystems numbers are.

    Now when you have created a partition and a filesystem, and you wrote the filesystem to disk, then you'll be all done. And to answer your second question... no this will not affect boot up. If you would like your new partition to be mounted at boot process then you will have to add it to your fstab, here is an example:

    /dev/hda4 /mnt/sparedrv ext3 defaults 0 0

    You have to edit /etc/fstab as root though in order for changes to take effect.

    after you have edited fstab then reboot and your new partition should be mounted.

    Any problems please post.

  11. #10
    Just Joined!
    Join Date
    Jul 2004
    Location
    /home/
    Posts
    9
    Well, thanks a lot, but I ended up reinstalling all the stuff (Linux/Windows), I created the partition I wanted during the instalation process, and everithing is going well!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •