Find the answer to your Linux question:
Results 1 to 6 of 6
somebody please help! i accidentally zipped my shadow file and rebooted my computer. so now I have only a shadow- and a shadow.gz file in /etc. i tried using knoppix ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    4

    help! i zipped my shadow file


    somebody please help!
    i accidentally zipped my shadow file and rebooted my computer.
    so now I have only a shadow- and a shadow.gz file in /etc.
    i tried using knoppix to rename shadow- or unzip shadow.gz but it says the file is read only and wont let me change the permissions on it.
    is there anyway to force a rename or get past the protection. it is my hard drive for school and all my work is on it. any help would be greatly appreciated. thanks

  2. #2
    Just Joined!
    Join Date
    Oct 2003
    Location
    The Netherlands
    Posts
    89
    you should be able to change it with knoppix...
    did you mount the drive read-writable??
    also try chown and chmod the file, i did this before by writing to my /etc/passwd and /etc/shadow file, so i don't see why you would not be able to change it...

    if you use a bootloader, try adding 1 to the kernel options, this will allow you to boot with runlevel 1 and that means logging in as root with (on most systems) no password required.. this also might be an option..

    let us know if you got it solved..

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    4
    i tried the chown and chmod using knoppix.

    how exactly do you do the bootloader option you mentioned?

    thanks.

  4. #4
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    to change to runlevel 1 you can boot normally and when u get into ur graphical desktop press alt+ctrl+F1 .then after typing passwords press telinit 1 or init 1 to change to runlevel 1(login as root).
    to change the permissions to the file u mentioned use chmod command ....
    Linux For Ever!

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    4
    I figured it out.

    i used a rescue disk and entered linux single then just went to the /etc dir and unzipped my shadow file.

    thanks for all the help though.

  6. #6
    Just Joined!
    Join Date
    Oct 2003
    Location
    The Netherlands
    Posts
    89
    i used a rescue disk and entered linux single then just went to the /etc dir and unzipped my shadow file.
    that is runlevel 1


    what i meant was, suppose you use grub, when you see the options to boot your partition at startup (in grub) just hit "a" to add extra kernel parameters to the boot, and all you have to do is type 1 at the end, that is <space> , 1 , because it must be seperated from the other options otherwise you will get an error...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •