Find the answer to your Linux question:
Results 1 to 3 of 3
Hi everyone! I've been looking for information on this problem but havne't been able to find anything. I hope that someone can help! When I install mandrake without the nvidia ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    4

    scrambled text in shell


    Hi everyone!

    I've been looking for information on this problem but havne't been able to find anything. I hope that someone can help!

    When I install mandrake without the nvidia drivers, I can go to a shell by pressing ctrl+alt+f2 and no problems.

    now that I've insttalled the nvidia drivers, when i do the same, i get scrambled characters. it looks like the shell resolution is set wrong or something and i have no idea on how to fix it..

    here's my xf86config-4 file:

    # ************************************************** ********************
    # Refer to the XF86Config man page for details about the format of
    # this file.
    # ************************************************** ********************

    Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
    EndSection

    Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    EndSection

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" ""
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
    EndSection

    Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "1280x1024 @ 74 Hz"
    HorizSync 31.5-79.0
    VertRefresh 50-90

    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
    EndSection

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce4 (generic)"
    Driver "nvidia"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
    Depth 8
    Virtual 1152 864
    EndSubsection

    Subsection "Display"
    Depth 15
    Virtual 1152 864
    EndSubsection

    Subsection "Display"
    Depth 16
    Virtual 1152 864
    EndSubsection

    Subsection "Display"
    Depth 24
    Virtual 1152 864
    EndSubsection
    EndSection

    Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
    EndSection

    if anyone can help, it would be MUCH appreciated!!

  2. #2
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Have you tried entering the command "reset" in the shell with garbled text? This usually works to set a shell's text encoding back to normal.
    Situations arise because of the weather,
    And no kinds of love are better than others.

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    4
    Thanks for the reply! yeah, I just tried 'reset' and you can tell that it clears the screen, but the characters are still really large and scrambled..

    Quote Originally Posted by dan@george
    Have you tried entering the command "reset" in the shell with garbled text? This usually works to set a shell's text encoding back to normal.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •