Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 27
I had decided yesterday night, to search for more files that mention anything about "USB" and about "scanner". And just now, I decided to use more of my comon sense ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Banned
    Join Date
    Oct 2007
    Posts
    219

    I had decided yesterday night, to search for more files that mention anything about "USB" and about "scanner".

    And just now, I decided to use more of my comon sense as well.

    I did just find a interesting file, and according to the decission and agreement I made with myself, I am changing this part of the file:

    from

    ----------------
    #!/bin/bash

    # Load bulk/interrupt transfer test firmware into
    # various EZ-USB USB devices that will run it

    FIRMWARE=/etc/udev/scripts/bpckusb.fw/
    FLAGS=
    # pre-renumeration device IDs
    case $PRODUCT in

    # BACKPACK USB2 INTERNAL ADAPTER

    #----------------------SCANNNERS SCANNERS-------------------------------
    #external usb1 scanner
    ac9/0/0)
    FIRMWARE+=BP1SCAN.HEX
    ;;

    #external usb2 scanner
    ac9/1/*)
    FIRMWARE+=BP2SCAN.HEX
    FLAGS="-2"
    ;;

    ---------------------------


    to:

    ----------------------------

    #!/bin/bash

    # Load bulk/interrupt transfer test firmware into
    # various EZ-USB USB devices that will run it

    FIRMWARE=/etc/udev/scripts/bpckusb.fw/
    FLAGS=
    # pre-renumeration device IDs
    case $PRODUCT in

    # BACKPACK USB2 INTERNAL ADAPTER

    #----------------------SCANNNERS SCANNERS-------------------------------
    #external usb1 scanner
    ac9/0/0)
    FIRMWARE+=BP1SCAN.HEX
    ;;

    external usb2 scanner
    ac9/1/*)
    FIRMWARE+=BP2SCAN.HEX
    FLAGS="-2"
    ;;
    ------------------------------------


    Comment:

    What did I do?: I took out one of these: "#", so that that function is no longer blocked, and can act.

    I only enabled the external usb2. - I guess it is a USB 0.2 connection. That is why.

    - ...Strange file: I never heard about it, nor saw it before. But "searching the haystack for a needle", is sometimes a good thing. Of course, mostly it is a stupid and timewasting thing to do. Not in this case.

    OK: Now lets see, what will happen after....

    I feel like a magician, trying to do the right trick...



    Cheers,
    Alexander

  2. #12
    Banned
    Join Date
    Oct 2007
    Posts
    219

    BACKPACK USB Loader

    Hello again.

    I haven't tried it out yet, if works, because I was looking for some information, explaing the backpack issue.

    Having read one interesting article, it looks like that I am on the right track, and possibly just did the right thing, or nearly right.

    I found the following article. Quote:

    ---------------

    Howdy all,

    I'm very pleased to be able to tell you that Micro Solutions
    has just made available the "BACKPACK USB Loader".

    It is available here:
    http://www.micro-solutions.com/softw...ux/index3.html

    This package provides the firmware and scripts to allow
    "BACKPACK USB" products (including USB2 products) to be used with the
    "linux-usb-storage" driver.

    This package ties into the usb-hotplug layer, so that the drive may simply
    be plugged in and it will be recognized as a linux-usb-storage device.

    This package depends on the linux-hotplug and fxload packages.
    If your distribution is missing these packages, you may wish to obtain them
    at:
    http://linux-hotplug.sourceforge.net/
    (look in the USB section)

    Thanks go to the usb-hotplug and linux-usb teams as well as the author of
    fxload. Oh and of course the obligatory thanks to all linux kernel
    developers for doing a great job.

    Hope this will help all Linux users of BACKPACK products,

    Ken Hahn
    Engineer, Micro Solutions

    ----------------

    So, lets go further from there. Anyway, sounds interesting.

    Errr....: And I did just check it out, what sort of USB connection my scanner has, and I am right about it: It has USB 2.0.
    Good...

    - All in all, it sounds like a USB backpack/hotplug/fxload issue, to be in need to be further examined.


    Alexander

  3. #13
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Hi again.
    I still haven't tested out my new configuration:

    I am a analyst type, and I like to know, what I am doing, before I press any buttons.

    So I am still reading about the subject/matter/issue.

    Here is a article from the same guy, as before. I couldn't find a date, but it looks like that it had been written before the last post. I just dug it out from the Internet.

    It has some other interesting information in it, that helps clarify the things, and that gives a better understanding.

    He is a engineer that did a job for Linux users. He made some software, that Linux did not have before, but was in need of.

    He seems to be showing a lot of goodwill and interest to help, and provide and share his know how and knowledge.

    So here, is that post:

    Quote:

    -----------------------------------------------

    So I was just on the Linux-USB list and it was recommended I take a look over
    here.

    I'm trying to get the Micro Solutions BACKPACK USB adapter supported under
    Linux.

    It's a simple mass-storage device, but it needs to have a firmware loaded
    (actually several, but it's a long story). Fxload and hotplug sure sound like
    the trick.

    My question:
    What should I be creating?

    Should I create a script for people to add the correct files in the right
    places for hotplug to get at, or should I be working to get firmwares to you
    folk so that it will be in the hotplug package?
    Perhaps there's another package that's going to be the repository of scripts
    for different devices?

    It seems simple enough, and I've got it roughly working on my machine here,
    but how is it going to be easy for the users? I'd like to have this be easy for
    people to add to their distributions. Make our own .deb's and .RPM's???? Is
    there a previously existent repository package?

    Thanks for any advice?

    Ken Hahn
    Engineer, Micro Solutions

    ---------------------------------------------


    Thank you,

    Alexander

  4. $spacer_open
    $spacer_close
  5. #14
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Wow!...: This is getting really interesting. Soooo interesting indeed.

    I followed the that tread. Here is a post from a other man that is communicating with that engineer. It is now about plugging in cameras. But nevertheless, it concerns the same issue.

    There is a lot of talk about hoplugs. So I will look into my directory, seeing what I can find about that.

    I am posting the link to the post here, or else it might get a little too lengthy here:

    http://osdir.com/ml/hotplug.devel/2001-11/msg00004.html

    I hope, the link works.



    Alexander



    P.S./Edit:

    Here is a cool comment refering to a other cool coment.:

    Quote:
    "very cool. i think doing things this way would make handling USB devices a
    little more 'hands-free' because it lets applications (via hotplug
    scripts) handle the nitty-gritty (permissions, ownership, mounting,
    etc...) and give the end-user a nicer experience."

    It is from the post:

    http://osdir.com/ml/hotplug.devel/2001-11/msg00010.html


    Ha, ha...:

    He calls the fiddling and configurating simply the "nitty-gritty" ...!

    ......nitty-gritty......... (I hope, this makes a smiley... - No smilies around?.... - When editing?...

    ...Nope.

  6. #15
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Here is another quote from that thread.

    You can see, that they where working really enthusiastic, hard and efficient on the issue.

    I think, it then was around the year 2002, if I am right.

    It looks like they have created some good software packages for the Linux system.

    Quote:

    "Yes it is. But it's a "USB device added" event. It might be nice if we
    have a "filesystem added" kernel event to /sbin/hotplug so that programs
    can realize that something new is out there to scan, without having to
    constantly parse /proc/partitions or some such file.

    One problem with mass storage devices, is that it might be tough to tell
    the difference from a filesystem on a USB floppy from that of one on a
    USB Camera."

    Link:
    Re: hotplug arch. and apps



    Alexander


    ...However: I see light at the end to the tunnel, and am beginning to understand (my problems).


    Alexander

  7. #16
    Banned
    Join Date
    Oct 2007
    Posts
    219
    About that interesting thread:

    I changed the end of link from, lik 10, or 17, to 01, and it looks like that was the very first post.

    To get to post number 02, I click left below, on "previous thread", and it brings you though to the next, to the follow up post. Just try it out, how it works for you.

    Here the link at 01:

    Re: Howto automatically mount multiple usb-storage devices?

    Reading that thread, you don't get the dry feeling in your mouth. It is not dry stuff, and not so abstract, that it would put you off.

    No: Just great stuff to read. Interesting, that Linux World. And interesting, to read about those developers and programmers, and how they did the software, and what sort of persons that they are.

    At least it seems to me, that they are pretty communicative, and great people to communicate with.

    No "out of the world" people, from some mountain valley, way from whatever...: No, they are right at the front, and know exactly, what the needs of the users are.

    Because sometimes creators do not know that, and just produce the wrong stuff for the consumers.
    And the consumers aren't happy then.

    Yes, consumers are happy, when they get useful and easy to use tools, for their computing.


    Alexander

  8. #17
    Banned
    Join Date
    Oct 2007
    Posts
    219
    I am focusing in the short term on the „log file“, and will note the output for:

    1.)Kernel
    2.)Cupsd
    3.)kooka
    4.)nmbd
    5.)other processes

    I am giving much attention to each message of the relevant processes, hoping to get some hints leading to discovering and solving some of the existing problems of the system.

    So here we have a first go and try („try ans error“, but analyzing first):


    Kooka

    unable to connect hpssd socket 2207: Connection refused: api/hplip_api.c 738

    unable to open /var/run/hplip/hpssd.port: No such file or directory: api/hplip_api.c 103


    Etc.


    I will continue to proceed in this way: I think that „Ksystemlog“, is a good and useful tool for troubleshooting.

    To each process, I will ad a few relevant messages that the process gave as a output, and then try to get a picture of the locations and their problems. And just follow the info of the messages.

    Further, I will try to put some messages from different processes into one group, if they look like to be a reason for one and the same problem. - Also, a mindmap would be good.

    I hope to have my scanner running within one day of further investigating the problem.

    Right now, I feel like watching some videos at blip.tv, so see you tomorrow.


    Alexander

  9. #18
    Banned
    Join Date
    Oct 2007
    Posts
    219
    P.S.:

    I recapitulate, where I presume, that the locations of the problems are (underlined):


    Scheme:


    User
    |
    Scan program (Frontend)
    |
    SANE-Backend
    |
    libusb
    |
    resmgr <-- PAM <-- Login
    |
    USB-Kernelmodule <-- hotplug <-- Attaching the scanner (Plug in)
    |
    USB-Hardware in your computer
    |
    USB-Kabel connection (evt. extra USB-Hubs)
    |
    Scanner


    Conclusion Nr.1:

    Problem locations are:

    1.) resmgr (configurations)

    2.) USB-kernel-module and hotplug issue (configurations)

    3.) Only configurations of USB-hardware, internal


    Ok, are:
    Installations and configurations of the Frontend, backend, as well as the libusb.
    Possibly, some problems with uncorrect run-commands, there.

    Also ok, are:
    The USB-hardware, the USB-cable, as well as the scanner.


    Biggest problem:
    Configurations about the issues of kernel-module and hotplug.

    Partly solved:
    Configuration of internal USB-hardware of laptop.


    Conclusion Nr.2:
    Stays mainly only two known issues to solve, and get a better understanding for the context of the problems, and knowing, where to find the right files, and how all works together, etc.


    Thank you, for your attention,

    Alexander

  10. #19
    Banned
    Join Date
    Oct 2007
    Posts
    219

    A little progress, behind the scene

    Report:


    The problem is, that the kernel of my system is not well prepared for a using of USB-devices.

    It should be from the 2.4 series, but it is in fact from the 2.2 series.

    Therefor, my kernel needs at least one patch, next to doing a lot of configurations.

    The kernel has to be configured in the USB-area.

    Nevertheless, it looks like the system is reacting to my configurations, and updating and configuring the system as well.

    So it might be only a matter of time, till we both manged to get the scanner running.

    The system is doing two things: It is giving me output in form of feedback and instructions to do needed configurations, and it is doing configurations, as well.

    The scanner is giving some new interesting sounds, and there is definitely a lot going on: Inside of the computer, and inside of the scanner. And they are both connected, so I am hoping...

    I can't keep my fingers crossed, because I need them for typing.

    Bye for now, see you very soon, in this thread.

    Don't miss the latest update of the USB-mystery!

    Alexander

  11. #20
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Hello.

    I pluged in my external HDD, into the same port, where my scanner will not work, just to see, how it would react:
    I received the following message:

    Quote:

    Could not mount device.
    The reported error was:
    mount: block device /dev/fd0 is write-protected, mounting read-only


    mount: wrong fs type, bad option, bad superblock on /dev/fd0,

    missing codepage or other error

    In some cases useful info is found in syslog
    try dmesg | tail or so


    I gave executable rights to /dev/fd0, but so far no changes happened.

    .---------------

    About the scan program Kooka, I am still getting the following message from Ksystemlog:

    Quote:

    unable to connect hpssd socket 2207: Connection refused: api/hplip_api.c 738

    So, I am trying to figure out, what this is all about...

    - Any ideas, hints, recommendations???


    Thank you, for your attention.

    Alexander

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •