Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 27 of 27
Hi, here a few snapshots of my scan program Kooka. No scan preview possble. Now select scan device possible. Only gallery and image viewer work. And I am able to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Banned
    Join Date
    Oct 2007
    Posts
    219

    Some snapshots of Kooka


    Hi,

    here a few snapshots of my scan program Kooka.

    No scan preview possble.

    Now select scan device possible.

    Only gallery and image viewer work. And I am able to print the pictures from the scan program to my printer.

    So, here the snapshots:

    snapshot1.jpg

    snapshot2.jpg

    snapshot3.jpg

  2. #22
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Latest news:

    I gave in the following command, and it reset all configurations to default, and deleted all files in the Gallery. So it is now a all in one screen, just as it was two weeks ago.

    Password:
    root@9[~]# su -c kooka
    kooka: cannot connect to X server


    See screenshot:

    snapshot4.jpg


    Alexander

  3. #23
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Howdy, everybody!...

    I thought, I must do some serious piece of fine work, for me, and for the whole Linux-community (scanner users), instead of chatting around, in th coffee lounge... -Right?.. Here goes:

    Installing a scanner on a Linux operation system:

    Methods for solving according to todays researching that I did:

    1.)controll all installed modules, and be assured, that you have them all in your directory:
    usbcore,
    usbhid,
    usb_storage,
    uhci_hcd,
    ehci_hcd

    The kernel of the Computer has to initialyse the USB Mass Storage driver.

    Then the driver would send commands to the scanner via USB-port and USB cable. Or similar.

    2.)

    Translated by Lordshooter, of the Italian solution, found today(, but it is for a pinter, not a scanner. Anyway...):
    Localhost:631 of the browser was not able to connect to the congigurations of CUPS.

    I did connect both things, and assured myself, that the interface of loopback is not activated.

    Now, back to the scanner issue:

    3.)

    The Linux-USB-scanner schedule/timetable:
    (Translated by Lordshooter from a German website: Linux Netmag, Kristian Rink.)

    Preparation:
    Download of the SANE-scanner drivers, unpack, configure,

    >> make && make install

    The hardware issue:
    If you have a USB-scanner, be sure, that the version of the driver does support USB-scanners.
    Optionally, you can download the lates software (SANE-patches), and install them according to the instructions.

    Choice of software/sofware installation:

    For USB use under GNU/Linux, it is highly recommended, that you have a kernel installed, from the 2.4 series, or higher. Because of a much better USB-functionality and stability, compared with the 2.2 series. Furthermore, the packages are easier to install this way, and don't need any patching.

    The kernel configuration:
    Together with your other settings, it is required, that you have the following settings within the USB-area, as well:
    -USB-support has to be activated (compiled or modul).
    -At least one USB-controller driver (UHCI for Intel-and VIA- Chip sets, OHCI for ALI-, SiS-Chip sets or iMacs), depending on the hardware you use in your computer.
    In case of doubt, this will bring you further:
    cat /proc/pci | grep USB

    -A USB-scanner support, as modul.


    After-configuration/after-settup:

    Applying a device-directory for USB-scanners:
    >> mknod /dev/usbscanner0 c 180 48 ... mknod /dev/usbscanner15 c 180 63
    (add as Root)
    Setting permissions, at least for the scanner to be used: chmod 666 /dev/usbscanner0
    Reading the manual of the scanner-driver, to be able to find additional information about the possible parameters for the kernel module.
    Load USB-controller-driver-module (if compiled as modul):
    >> modprobe usb-uhci
    respectively,
    >> modprobe usb-ohci
    Possible options for the actuall scanner-driver, itself, here, as a example with the EPSON Perfection 1200U: Inserting the line:
    >> options scanner vendor=0x04b8 product=0x0104
    in to /etc/modules.config
    Debian-user: The options are inserted in the same manner, in /etc/modutils/aliases and after, execute:
    >> update-modules

    Loading the scanner driver:

    modprobe scanner

    Configuring SANE:

    Mostly through editing the:
    (/usr)/etc/sane.d/<scanner driver name>.conf

    Testing:

    scanimage -L
    Should show after, the name of the scanner, so that there is access from the scan program to the scanner.


    Good luck!


    Kind regards,
    Alexander

  4. $spacer_open
    $spacer_close
  5. #24
    Banned
    Join Date
    Oct 2007
    Posts
    219

    The interfering file.

    Interfering File

    A post from Newsgroups.de, Meinews.de, Germany.
    Newsgroup de.comp.os.unix.linux.misc

    Thread:
    „Ubuntu 6.06: xsane, suddenly won't run anymore“


    Part of post from Josef Erbach, Germany. Translated by Lordshooter.


    Excursion:
    Josef, suddenly couldn't use his scanner anymore (mustek 1200 CU).

    Quote:
    Translation:

    „There was however a file hplib in my directory /etc/sane.d/dll.d .
    No matter, how it happened, or by whom it was put there...
    I moved it into a security directory, so that /etc/sane.d/dll.d now is empty.

    I am able to start up with xsane, again, as well as direct, or as well as from gimp.

    I have no idea, if some sort of other problem may occur from the file transfer: I will see, if
    anything happens

    Josef“



    So, I will try this out...

    Could anybody recommend, where to put that hplib file? - I guess, there is a folder for that already existing...

    Ok: I shall do something, and give you feedback.

    Posts welcome...

    I hope this does the trick...., because I checked it out, and I also have that file in the same folder.
    So I shall take it out, and see...


    Alexander

  6. #25
    Banned
    Join Date
    Oct 2007
    Posts
    219

    Interfering file: Once again!


    Scanner setup in Kubuntu: Interfering file: Once again! Got you!

    Quote:

    ----------------------------


    #1
    Old July 29th, 2007
    wcj786 wcj786 is offline
    Spilled the Beans

    Join Date: Jul 2007
    Beans: 14
    Canon MP600 Scanner Setup In Kubuntu
    These procedures were put in another post, but I thought it might be advantageous for this to be the first entry in a new post, so people would not have to go searching around to find it. These steps were what allowed the scanner to work for me in Kubuntu.

    For those looking to get there Canon MP600 scanner working, I found a web page that shows how to get a Canon scanner to work in Dapper, here, but had to slightly modify it, due to the MP600 working on the 0.13.0 back-end. Here are the steps I took to get it to work.

    1) Downloaded the drivers to Desktop

    2) cd Desktop

    3) sudo apt-get install alien libpng3
    sudo alien scangearmp-common-1.00-1.i386.rpm
    sudo alien scangearmp-mp600-1.00-1.i386.rpm
    sudo dpkg -i scangearmp-common_1.00-2_i386.deb
    sudo dpkg -i scangearmp-mp600_1.00-2_i386.deb

    At this point, it was suggested that you should be able to run scangearmp. This did not work for me. That is not to say it is wrong, it might be that the person who suggested it had other software that allowed it to run, where I didn’t, so I then did the following:

    4) sudo apt-get install build-essential
    wget http://home.arcor.de/wittawat/pixma/...0.13.0.tar.bz2
    sudo tar xjf mp150-0.13.0.tar.bz2 -C /usr/src
    cd /usr/src/mp150-0.13.0/
    sudo make
    sudo ./scan -L

    5) sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.0.13.0
    sudo ln -s /usr/lib/sane/libsane-pixma.so.0.13.0 /usr/lib/sane/libsane-pixma.so.1
    (The web page states to modify dll.conf, but I found that pixma was already in the file.)

    6) sudo vi /etc/udev/rules.d/45-libsane.rules (I use vim as my editor.)

    At this point, I added the following lines in this file (in the area that had the Canon AiO/scanners):

    # Pixma MP600
    SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="1718", MODE="664", GROUP="scanner"

    7) sudo /etc/init.d/udev restart

    This is the end of the directions from that webpage, but at this point, the scanner still did not work for me (and scangearmp was not showing up in my K Menu under Graphics).

    So, I started looking in the /etc/sane.d/dll.d folder to see if there was anything in there that might be causing the problem. I identified that the only file in that folder was hplip. So , I copied that file, then modified it, naming the new file pixmalip. I added the following four lines in the in the new file:

    # dll.conf snippet for pixmalip
    #

    canonaio (this is the last line of the file and does not include the comments in the parentheses)

    In the sane.d directory, I also modified the canon.conf file to look like:

    #canon.conf
    # Canon Pixma MP600 (This was not there originally.)
    usb 0x04a9 0x1718 (This was not there originally.)
    #/dev/scanner (This was not commented out originally.)
    #/dev/sg0

    After doing the above steps, I got the scangearmp program to run and scan for me. I am sure there may be steps that I took, that might not be necessary, and there may be a better way of doing this, but this is what worked for me. I do not profess to know how to program in Linux. The steps I took were more of a "follow the procedures on the web page" approach, with some slight modifications, due to the differences in equipment and files.

    The last few steps that included adding the pixmalip file and modifying the canon.conf file seemed like the logical thing to do. I am not claiming that this procedure will work for everybody, just that it worked for me. If anybody can identify a better way to provide the scanner capability, or modify the above code to work more efficieantly, please do not hesitate to post that info.

    ---------------------------
    End of Quote.

    ----------------------------------

    Thanks you, for your attention,
    Alexander

  7. #26
    Banned
    Join Date
    Oct 2007
    Posts
    219
    For the very first time under Linux, my scanner is getting alive: I can hear all sorts of clicking sounds. I is obious, that he is working hard.

    Tutti Frutti, again: Just read and pick out, what you find interesting and useful.

    Dear friends,

    Here is some informtion about hplip, from the RedHat Security Advisory.
    I translated if from German.
    hplip is a program, provided by Hewlett Packard, that enables to use Hewlett Packard printers and scanners on Linux.

    The weaknesses/flaw of hplip:
    The hplip hpssd daemon uses the function popen3 in a unsecure way and manner.
    A local attacker can send special constructed requests to the daemon and then execute any commands with administrator permissions.


    Other comments:
    Quote from Till Kamppeter:

    „there is "hpaio" in both /etc/sane.d/dll.conf and /etc/sane.d/dll.d/hplip. Most probably one is enough. There is no /etc/sane.d/hpaio.conf. Perhaps you need the /etc/sane.d/hpaio.conf as your device is a very new model and its USB IDs are not yet added to the current HPLIP driver.“

    Quote from rooker:

    „"sane-find-scanner" lists the scanner, but "scanimage -L" says "No scanners were identified.", even after restarting "/etc/init.d/hplip". It seems like the right sane backend is simply missing. Regarding sane and backends, these are the packages that I have installed:
    sane
    sane-utils
    libsane
    libsane-extras

    Quote from a System Info page:

    ----------------------
    > | SANE CONFIGURATION |
    > ----------------------
    >
    > 'hpaio' in /etc/sane.d/dll.conf'...
    > error: Not found. SANE backend 'hpaio' not properly setup (needs to be
    > added to /etc/sane.d/dll.conf).
    >
    > Checking output of 'scanimage -L'...
    > device `v4l:/dev/video1' is a Noname UNKNOWN/GENERIC virtual device
    > device `v4l:/dev/video0' is a Noname UNKNOWN/GENERIC virtual device
    > device `hpaio:/usb/officejet_5500_series?serial=MY42QF209H96' is a hp
    > officejet_5500_series multi-function peripheral
    > default device is `hpaio:/usb/officejet_5500_series?serial=MY42QF209H96'"



    Alexander

  8. #27
    Banned
    Join Date
    Oct 2007
    Posts
    219
    Resetting the screen again.

    New output:


    alexander@2[~]$ su -c kooka
    Password:
    kbuildsycoca running...
    KWrited - Listening on Device /dev/pts/3
    kded: Launching previous backup analyse.



    hpiod 1.7.1 accepting connections at 2208...

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •