Find the answer to your Linux question:
Results 1 to 4 of 4
when i tried to run the xf86config command i get errot saying no such command or bad command line can anyonw help plz...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    39

    running command errors


    when i tried to run the xf86config command i get errot saying no such command or bad command line can anyonw help plz

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try xorgconfig.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Try typing "locate xf86config" at the terminal. This should find any files in system directories with "xf86config" in the name. You should find one in /usr/bin/X11. Now all you have to do is put this directory in your PATH environment variable, which tells Linux where to look for the programs that correspond to the commands you type in. PATH is a colon-separated string of all the paths that Linux will search. For example, my PATH variable, which I can look at by typing "echo $PATH", looks like this:
    Code:
    /usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/home/dan
    Yours should look similar, and it should definitely contain the /usr/bin/X11 path, since that's where xf86config is, and you don't want to have to type "/usr/bin/X11/xf86config" every time you want to run it. So here's how to add a new path to your PATH variable:
    Code:
    PATH = $PATH:/usr/bin/X11
    This means to take the current value of PATH ($PATH),add the string after it, and make that the new value of PATH. Hope this helps!
    Situations arise because of the weather,
    And no kinds of love are better than others.

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Are you logged on as "root"? The 'bash: :command not found' response can be confusing, 'cause you know it worked before... You get something similar when you try to cat a file or ls a directory that you don't have proper permissions to. Most configuration-related files and commands require root permissions. Usually, you can be superuser (su), but I think for xf86config you have to be root.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •