Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I am trying to mount my windows partition in Slackware so that I can use my music, etc. I've read about mounting, so I think I should know how to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7

    Mounting Problems


    I am trying to mount my windows partition in Slackware so that I can use my music, etc. I've read about mounting, so I think I should know how to do it, but the problem is that when I mount the partition, the permissions are 500, but I want all users to be able to read it. The command I am using is:

    mount /dev/hda1 /win-c

    Just for the sake of trying to fix this, I changed the permissions of /dev/hda1 and /win-c to 777. But after the partition is mounted, /win-c shows up as 500. What can I do to fix this?

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    did you do that as root?if so there is no reason permissions to change to 500 after setting them to 777(rwx for all)..
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    Yup. I just tried again, and here are the relevant parts of what I did:

    Code:
    jeff@BitterAssRose:~$ su
    Password:
    root@BitterAssRose:/home/jeff# umount /dev/hda1
    
    root@BitterAssRose:/home/jeff# chmod 777 /dev/hda1
    root@BitterAssRose:/home/jeff# chmod 777 /win-c
    
    root@BitterAssRose:/home/jeff# mount /dev/hda1 /win-c
    root@BitterAssRose:/home/jeff# ls -l /
    [...]
    dr-x------   1 root root  8192 2004-07-18 08:17 win-c

  4. #4
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    After the "mount /dev/hda1 /win-c", run "chmod 555 /win-c"

    Jason

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    Oh yeah, I probably should have mentioned that I tried to chmod before I started messing around with anything else.

    Code:
    root@BitterAssRose:/home/jeff# chmod 555 /win-c
    chmod: changing permissions of `/win-c': Read-only file system


  6. #6
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    hmm...

    you could try unmounting the drive, then try to force it to be mounted writeable, eg "mount -w /dev/hda1 /win-c"

    Is it NTFS or FAT32 btw?

    Jason

  7. #7
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    It's NTFS. I've not wanted to mount it as writeable because I've heard that it's dangerous to write to NTFS in Linux. Would it be safe though to just do that and change the permissions then change it back?

  8. #8
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    Dammit, even with the -w, it says it's read only.

  9. #9
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    I didn't realize that Linux could read NTFS, I had broken up my external HD's into 4 separate partitions in FAT32 so I could transfer data, but have been continualy frusterated with the instability, especaily when writing video. So linux can read NTFS, but no write, and read/write from FAT32?
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  10. #10
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    Yes, Linux can definately read NTFS. I am listening to MP3s from my NTFS partition as I write this, my problem is that I have to be logged in as root to do so. There is supposed to be write support for NTFS in the latest Linux kernel, but it is supposed to be terribly dangerous.

    I don't have experience with FAT32 in Linux, but everything that I have read says that yes, you can read and write to it.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •