Find the answer to your Linux question:
Results 1 to 2 of 2
Dear Friends, I am using RedHat Linux Advanced Server 2.1. It containsonly 3 partitions /, /var and Swap. Accidently i deleted /home directory using "rm -rf" command. The biggest pblm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Bangalore, India
    Posts
    1

    Recovering deleted files in RedHat Linux Advanced Server 2.1


    Dear Friends,

    I am using RedHat Linux Advanced Server 2.1. It containsonly 3 partitions /, /var and Swap. Accidently i deleted /home directory using "rm -rf" command. The biggest pblm now is i am not having any backup also. The entire /home directory is lost. It contains many useful information and codes. I need to recover it as soon as possible.
    I browsed in NET and found that using "debugfs" command, it is possible to get back the lost contents. But the procedure suggest to first unmount the corresponding partition. Since i am not having a seperate /home partition, it is in / partition only. On trying to unmount it, it displays, Drive or Resource is busy. I even tried booting via Installable CD, getting into Rescue mode and tried to Unmount it. Still it displays the same error and the output of "mount" also displays an entry for /dev/hda1 mounted as /.

    Pl. help me to resolve the issue.

    Warm Regards,
    R.Gopalakrishnan

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    try http://www.sysresccd.org/. this distro is suppose to be nice for doing rescue type stuff that you need.

    also, think about aliasing so this doesn't happen again. try running the following three commands in a terminal window.

    alias cp='cp -i'
    alias rm='rm -i'
    alias mv='mv -i'

    good luck with getting your data back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •