Find the answer to your Linux question:
Results 1 to 2 of 2
hi i tried installing sudo by using commands "./configure, make test ,make install".configure worked.but other cmds give the following error. [root@localhost sudo-1.6.9p10]# make test make: *** No rule to make ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    19

    problem installing sudo 1.6 in fc6


    hi
    i tried installing sudo by using commands "./configure, make test ,make install".configure worked.but other cmds give the following error.

    [root@localhost sudo-1.6.9p10]# make test
    make: *** No rule to make target `test'. Stop.
    [root@localhost sudo-1.6.9p10]# make install
    /bin/sh ./mkinstalldirs /usr/local/bin \
    /usr/local/sbin /etc \
    /usr/local/share/man/man8 /usr/local/share/man/man5 \
    /usr/local/libexec
    gcc -o sudo check.o env.o getspwuid.o gettime.o goodpath.o fileops.o find_path.o interfaces.o logging.o parse.o set_perms.o sudo.o sudo_edit.o tgetpass.o zero_bytes.o sudo_auth.o passwd.o sudo.tab.o lex.yy.o alloc.o defaults.o strlcpy.o strlcat.o closefrom.o -lpam -ldl -lcrypt
    /usr/bin/ld: cannot find -lpam
    collect2: ld returned 1 exit status
    make: *** [sudo] Error 1
    [root@localhost sudo-1.6.9p10]#

    plz help me

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You should use yum to install packages instead of compiling those.
    Code:
    yum -y install sudo
    It will take care of all dependencies.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •