I've attempted to install java via adept manager, but there's a dialog during the installation that is inaccessible via adept, so I stopped the installation, planning to install via apt-get.

Now when I try to install, either sun-java6-bin (which is signaled as installed) or sun-java6-jre (not installed), I receive this message:

"The package sun-java6-bin needs to be reinstalled, but I can't find an archive for it"

I can't even uninstall it, the message is the same...

I can install or uninstall anything, by the way, I got this message, whatever I'm attempting to install or uninstall.

At one moment I was asked to do the well known sudo dpkg --configure -a, and it apparently solved what it was supposed to solve, but not the whole situation.

What should I do?


______________________________________

UPDATE: Solved. Hopefully.

Okay, I got it. dpkg --remove --force-remove-reinstreq sun-java6-bin. Now I'm installing via apt-get, apparently it will be fine, despite of some scary warnings, that I should reinstall before removing... but I had no option anyaway, and besides, was somewhat pointless since it didn't give me the option to not do it.