Find the answer to your Linux question:
Results 1 to 7 of 7
Alright i've probably looked through many forums for a real simple solution, unfortunantly i have not found one. I'm running Xubuntu 7.1 Gusty Gibbion on an HP6000t. The system is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    4

    OS automatically restarts on own


    Alright i've probably looked through many forums for a real simple solution, unfortunantly i have not found one.

    I'm running Xubuntu 7.1 Gusty Gibbion on an HP6000t.

    The system is stable and not giving much trouble and i've got the graphic drive running fine too with wireless. The system is really stable and hasn't crashed and I really haven't had much trouble.

    The only issue is that I've had my system restart on me out of the blue without warning. It always brings me back to startup on the HP logo. I'm barely running a lot of processes and on my CPU running only about 15% at max. My memory usage is less than to about 256 MB and not going above that. I'm not having trouble with the grub or my other partion running Xp which is runnign fine.

    I'm speculating that it's some init file on boot but I haven't found the correct file or code. I'm looking for any CLI way or direct way to edit this issue. Any help would be fine.

    Thanks.

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    How is your system temperature? Could it be resetting because of overheating? Are your fans running properly?

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    4
    As far as fan and temperature is concenced, The fans have been functioning and not churning away. My laptop is pretty well ventelated and I don't force it needlessly.

    Tempertautre ranges around 114 F degrees at norm but can jump to 123 F if processing something something intensive (in particular flv videos). In either case, my laptop resets at the norm without having something processeed intensively.

    I think i may have an idea of why this is happening. I did at one point set my laptop acpi to laptop mode. However, my system resetted before I installled the bash file while i was configuring nvidia driver and at another instance when I was on the web. Is it possible that could be resetting the system automatically?

    btw....i'm usually getting my system stats from conky.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you installed proprietary Nvidia Driver? Which Graphics Driver are you using right now?
    Execute this
    Code:
    lspci | grep VGA
    cat /etc/X11/xorg.conf | grep driver
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    4
    the output for the pci devices detects my GeForce Go 7400 with this output:

    01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1)

    that's odd i'm not getting output from the cat command.

    I called gedit to call the xorg.conf and it does look like my driver is configuered correctly.

    Here's the xorg.conf to see for yourself:

    Section "Files"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizEdgeScroll" "0"
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "USB" "on"# USB FLAG
    Option "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/input/wacom"
    Option "Type" "eraser"
    Option "USB" "on"# USB FLAG
    Option "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/input/wacom"
    Option "Type" "cursor"
    Option "USB" "on"# USB FLAG
    Option "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection

    Section "Device"
    Identifier "nVidia Corporation G72M [GeForce Go 7400]"
    Boardname "NVIDIA GeForce 7 Series"
    Busid "PCI:1:0:0"
    Driver "nvidia"
    Screen 0
    Vendorname "NVIDIA"
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Vendorname "Generic LCD Display"
    Modelname "LCD Panel 1400x1050"
    Horizsync 31.5-65.5
    Vertrefresh 56.0 - 65.0
    modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
    modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
    modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
    modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
    Gamma 1.0
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "nVidia Corporation G72M [GeForce Go 7400]"
    Monitor "Generic Monitor"
    Defaultdepth 24
    SubSection "Display"
    Depth 24
    Virtual 1400 1050
    Modes "1400x1050@60" "1280x1024@60" "1280x960@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    screen 0 "Default Screen" 0 0
    Inputdevice "Generic Keyboard"
    Inputdevice "Configured Mouse"

    # Uncomment if you have a wacom tablet
    Inputdevice "stylus" "SendCoreEvents"
    Inputdevice "cursor" "SendCoreEvents"
    Inputdevice "eraser" "SendCoreEvents"
    Inputdevice "Synaptics Touchpad"
    EndSection
    Section "Module"
    Load "algx"
    Load "glx"
    Load "v4l"
    EndSection
    Section "device" #
    Identifier "device1"
    Boardname "NVIDIA GeForce 7 Series"
    Busid "PCI:1:0:0"
    Driver "nvidia"
    Screen 1
    Vendorname "NVIDIA"
    EndSection
    Section "screen" #
    Identifier "screen1"
    Device "device1"
    Defaultdepth 24
    Monitor "monitor1"
    SubSection "Display"
    Depth 24
    Modes "640x480@60"
    EndSubSection
    EndSection
    Section "monitor" #
    Identifier "monitor1"
    Vendorname "Plug 'n' Play"
    Modelname "Plug 'n' Play"
    modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    Gamma 1.0
    EndSection
    Section "ServerFlags"
    EndSection

    I doubt this is any indicator of the issue of my sudden system restarts on random occassions, because i'm running compiz without a problem.

    Maybe i'm just being just freaking out over nothing, but these random restarts when i running no application is a little unsettling.

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    xorg.conf file is correct. Install htop and check after regular intervals if any process is consuming higher CPU cycles.
    Code:
    sudo apt-get update
    sudo apt-get install htop
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Dec 2007
    Posts
    10
    Another couple things to try:
    Check your kernel's message log for any information. From the command line, type 'dmesg | more'. Are there any acpi errors or anything else that catches your eye in there? dmesg will have all of the kernel's output when detecting your hardware, loading drivers, and working with your hardware.

    Test your memory. Linux is very stable. Twice I have had unexplained application and whole system crashes as well as random reboots. Both times it turned out I had a bad stick of memory. Check out Memtest86.com - Memory Diagnostic

    Download that, burn it on a CD, boot it up and let it run for an hour or two.

    Good luck to you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •