Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
can any one give me a fully detailed explanation on how to install the nvidia drivers...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2004
    Posts
    39

    can any one give me a fully detailed explanation on how to install the nvidia drivers

  2. #12
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    after entering the runlevel, cd your way to the folder with the driver, then type
    Code:
    ./<nvidadrivername>
    it wil run a script to install.
    that's it!
    then reboot. when nvidia logo appears you have succesfuly installed the drivers. then the only thing you have to do is to enable 3d support.
    manually check the /etyc/X11/xf86config to see which section module. it shouldn't contain "dri". then check section device and make sure that driver is set to "nvidia" not nv.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #13
    Just Joined!
    Join Date
    Jul 2004
    Posts
    39
    I figured the whole cd"ing thing now when i try to install it tells me that i cant i get this error
    ERROR:this .run file is intended for the linux-x86_64 platform,but you appear to be running on linux-x86.Abotying installation
    how would i go about fixing this or did i download the wrong file

  4. #14
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    It looks like you downloaded the package for 64-bit processor architectures, when you don't have one. Download the regular x86 package instead.

  5. #15
    Just Joined!
    Join Date
    Jul 2004
    Posts
    39
    ok now thati downloaded the right one and i run it it says somehting about the kernel i think i need to update it how would i go about doing this

  6. #16
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Could you please post the exact error message?

  7. #17
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    Quote Originally Posted by Linux_newb
    I figured the whole cd"ing thing now when i try to install it tells me that i cant i get this error
    ERROR:this .run file is intended for the linux-x86_64 platform,but you appear to be running on linux-x86.Abotying installation
    how would i go about fixing this or did i download the wrong file
    It sounds like you downloaded the 64bit driver, and you have a 32bit processor.
    --monkey

  8. #18
    Just Joined!
    Join Date
    Jul 2004
    Posts
    39
    ok now when i try to install the right updated drivers for mandrake it starts of good i press accept for the license aggrements and then this
    ERROR:unable to find the kernel source tree for the currently running kernel.Please make sure that you have installed the kernel source files for youre kernel:on redhat linux systems,for example,be sure you have the "kernel-dource"rpm installed you mayspcify the kernel source path with the "--kernel-source-path" commandline option

  9. #19
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    OK, it wants to know where the source code for your kernel is. I don't think Mandrake 10 installs this by default, but if you're still using the default kernel, you should download this:
    http://rpmfind.net/linux/RPM/mandrak...7mdk.i586.html
    and install it. Install it by cd-ing to the directory to which you downloaded it and typing, as root,
    Code:
    rpm -i kernel-source-2.6.3-7mdk.i586.rpm
    (actually, once you type a bit of that filename you should be able to just press tab and have Linux fill in the rest for you).

    Once this package is installed, you shouldn't get that error message anymore.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •