Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
as it says, it wont let me write to a freshly formatted drive i just formatted it to ext3 and i can mount the drive, but it wont let me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! phantommaggot's Avatar
    Join Date
    Jan 2007
    Posts
    47

    cant write to empty drive??


    as it says, it wont let me write to a freshly formatted drive

    i just formatted it to ext3 and i can mount the drive, but it wont let me write to it.
    i want to move my files from /home over there. (like music/vids/pics n stuff)

    im using mint 4.0

    i formatted it using gparted on the live mint disk

    the only thing i knew to try was right clicking it and enabling read/write but it says:

    "Sorry, couldn't change the permissions of "149.0 GB Volume"."

    id like to rename this drive and be able to write to it

    thanks!

  2. #2
    Just Joined! T3ddy's Avatar
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    19
    Quote Originally Posted by phantommaggot View Post
    as it says, it wont let me write to a freshly formatted drive

    i just formatted it to ext3 and i can mount the drive, but it wont let me write to it.
    i want to move my files from /home over there. (like music/vids/pics n stuff)

    im using mint 4.0

    i formatted it using gparted on the live mint disk

    the only thing i knew to try was right clicking it and enabling read/write but it says:

    "Sorry, couldn't change the permissions of "149.0 GB Volume"."

    id like to rename this drive and be able to write to it

    thanks!
    You don't have permission yet to write to the drive. In Linux (or any Unix) certain users are given certain permissions to do things (like access files or drives).

    So you need to change your permissions in order for it to work.

    this should get it to work:

    sudo chmod ugo+rw /nameofmountpoint

    to rename:

    sudo nano /etc/fstab

    and change the name of the second entry of the drive: (for example change: /dev/sda4 /media/originalname to /dev/sda4 /media/newname) or whatever the case may be.

  3. #3
    Just Joined! phantommaggot's Avatar
    Join Date
    Jan 2007
    Posts
    47
    ok
    doing this
    sudo chmod ugo+rw /media/disk (what the properties said the mount point was)
    just made the drop down bars in the properties menu not useable, as in they would no longer drop down.

    shouldnt the mount point be /media/sdb1 tho?

    and sdb isnt showing up in the fstab either

    Code:
      GNU nano 2.0.6               File: /etc/fstab                                     
    
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda5
    UUID=3872536f-2d30-4b95-aca5-27266f31d3dd /               ext3    defaults,errors=r$
    # /dev/sda7
    UUID=9f854564-a10d-4749-9dd9-2c5322bbbb14 /home           ext3    defaults        0$
    # /dev/sda1
    UUID=B4A0F6A3A0F66AEE /media/sda1     ntfs    defaults,umask=007,gid=46 0       1
    # /dev/sda6
    UUID=cde9efa6-f93b-498f-80cd-3c3ca577ca3c none            swap    sw              0$
    /dev/hda        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
    /dev/hdc        /media/cdrom1   udf,iso9660 user,noauto,exec 0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0

  4. #4
    Just Joined! T3ddy's Avatar
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    19
    Quote Originally Posted by phantommaggot View Post
    ok
    doing this
    sudo chmod ugo+rw /media/disk (what the properties said the mount point was)
    just made the drop down bars in the properties menu not useable, as in they would no longer drop down.

    shouldnt the mount point be /media/sdb1 tho?

    and sdb isnt showing up in the fstab either



    Code:
      GNU nano 2.0.6               File: /etc/fstab                                     
    
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda5
    UUID=3872536f-2d30-4b95-aca5-27266f31d3dd /               ext3    defaults,errors=r$
    # /dev/sda7
    UUID=9f854564-a10d-4749-9dd9-2c5322bbbb14 /home           ext3    defaults        0$
    # /dev/sda1
    UUID=B4A0F6A3A0F66AEE /media/sda1     ntfs    defaults,umask=007,gid=46 0       1
    # /dev/sda6
    UUID=cde9efa6-f93b-498f-80cd-3c3ca577ca3c none            swap    sw              0$
    /dev/hda        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
    /dev/hdc        /media/cdrom1   udf,iso9660 user,noauto,exec 0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0
    ls -la /media/disk

    that will tell you the device it's linking to (/dev/sdxy).

    Then add this line to your fstab:

    /dev/sdxy /media/disk ext3 defaults 0 0

    save and then type:
    mount /dev/sdxy

    Then see what it does.

  5. #5
    Just Joined! phantommaggot's Avatar
    Join Date
    Jan 2007
    Posts
    47
    Code:
    josh@Maggot:~$ ls -la /media/disk
    total 24
    drwxrwxrwx 3 root root  4096 2008-01-13 14:16 .
    drwxr-xr-x 7 root root  4096 2008-01-13 20:28 ..
    drwx------ 2 root root 16384 2008-01-13 14:16 lost+found
    josh@Maggot:~$
    so instead of sdxy id type drwx

    do i type
    Code:
    sudo gedit /etc/fstab
    ok
    did that..
    typed mount code
    said this
    Code:
    josh@Maggot:~$ mount /dev/drwx
    mount: according to mtab, /dev/sdb1 is already mounted on /media/disk
    mount failed
    josh@Maggot:~$
    so, its already mounted.. but i still cant write to it.....

    **add
    i right click unmounted the drive under computer
    then i went back to the terminal and did this..
    Code:
    You will visit the Dung Pits of Glive soon.
    josh@Maggot:~$ mount /dev/drwx
    mount: only root can mount /dev/drwx on /media/disk
    josh@Maggot:~$ sudo -i
    [sudo] password for josh:
    The better part of valor is discretion.
                    -- William Shakespeare, "Henry IV"
    root@Maggot:~# mount /dev/drwx
    mount: mount point /media/disk does not exist
    root@Maggot:~#

  6. #6
    Just Joined! T3ddy's Avatar
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    19
    Quote Originally Posted by phantommaggot View Post
    Code:
    josh@Maggot:~$ ls -la /media/disk
    total 24
    drwxrwxrwx 3 root root  4096 2008-01-13 14:16 .
    drwxr-xr-x 7 root root  4096 2008-01-13 20:28 ..
    drwx------ 2 root root 16384 2008-01-13 14:16 lost+found
    josh@Maggot:~$
    so instead of sdxy id type drwx

    do i type
    Code:
    sudo gedit /etc/fstab
    ok
    did that..
    typed mount code
    said this
    Code:
    josh@Maggot:~$ mount /dev/drwx
    mount: according to mtab, /dev/sdb1 is already mounted on /media/disk
    mount failed
    josh@Maggot:~$
    so, its already mounted.. but i still cant write to it.....

    **add
    i right click unmounted the drive under computer
    then i went back to the terminal and did this..
    Code:
    You will visit the Dung Pits of Glive soon.
    josh@Maggot:~$ mount /dev/drwx
    mount: only root can mount /dev/drwx on /media/disk
    josh@Maggot:~$ sudo -i
    [sudo] password for josh:
    The better part of valor is discretion.
                    -- William Shakespeare, "Henry IV"
    root@Maggot:~# mount /dev/drwx
    mount: mount point /media/disk does not exist
    root@Maggot:~#
    I'm sorry, but I had to chuckle at that. drwx isn't the name of the drive, but refers to two things: d means it's a directory and rwx means read,write,execution abilitities.

    Hmmmm... perhaps I'm not good at explaining this, maybe someone else can try to help you out. Best of luck to you.

  7. #7
    Just Joined! phantommaggot's Avatar
    Join Date
    Jan 2007
    Posts
    47
    i mean, i didnt know..

    so what does that mean..

    since it didnt show sdxy

    im really stuck here lol

  8. #8
    Linux User peteh's Avatar
    Join Date
    Oct 2006
    Location
    UK
    Posts
    339
    You were almost right to start with. If I'm correct then your partition is already mounted so when you right clicked to change permissions you were on the right lines but you need to be root and I don't think Ubuntu lets you do that with th GUI.
    Code:
    sudo chown -R your_username /mountpoint_name/
    That should change ownership of the entire mount. You can then do what you want with it.
    Pete

  9. #9
    Just Joined! phantommaggot's Avatar
    Join Date
    Jan 2007
    Posts
    47
    --** edit
    looks like i posted this at the same time as the guy above me..
    ill try that and get back..
    --**

    OK
    i don't know if this helps or not, but heres a pic of my volume properties. (rw is in there)
    and one of the basic properties where it looks as if it dosen't know anything about the drive. and i cant believe lost and found uses almost 8 gigs..


  10. #10
    Just Joined! phantommaggot's Avatar
    Join Date
    Jan 2007
    Posts
    47
    well i messed around with that line of code up there and finally got it..
    thanks a lot!
    if i had a root account and just logged in as root would it have worked that way as well ? (im about to reinstall and am strongly considering a root account)
    also, if i had a root account could i still sudo -i into root from the normal account..


    anyways
    thanks alot
    hopefully this will keep working for a little while and i can get everything fixed..

    i still have to figure out how to make it boot with more than 2 drives
    i know that its relabeling my OS drive as sdb once i plug the third drive in..
    but o dont know what in fstab to change.. or if i can even change it without the live disk (i aslo cant find my fstab with the disk.. i just get a blank page for what im assuming is the disks fstab) (if any of that made sense)

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •