Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I've already posted once today about my PC at work and Linux. I've also installed it on a laptop at home. SUSE is extremely slow. Horribly slow!! I've got ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22

    SUSE 9.1 on laptop


    Hi, I've already posted once today about my PC at work and Linux.

    I've also installed it on a laptop at home. SUSE is extremely slow. Horribly slow!!

    I've got a list of numerous unknown devices which I can only assume is causing SUSEs problems.

    I've found the driver for my ATI Mobility Radeon 9000 M9, but that leaves a large amount outstanding.

    Here is my list:

    Intel 82801BA/CA/DB/EB PCI Bridge
    Intel 82845G/GL Chipset Bridge
    Intel P4 CPU 2.66ghz

    Uniwill 82801DB/DBM SMBus Controller
    Uniwill 82845G/GL Chipset Host Bridge
    Uniwill IEEE 1394 Host Controller
    Uniwill OZ6912 Cardbus Controller

    Belkin 11mbps Wireless LAN Card.

    I'm having quite alot of difficulty locating any of the drivers for my SUSE installation.

    Does it matter that they show up as unknown on the YESt thing? Would this be the cause for my laptops slowness when running SUSE. It runs perfectly well under XP.

    Cheers for any help.

    Neil.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try enabling DMA on your hard drive:

    (as root)
    Code:
    hdparm -d1 /dev/hdx
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22
    Hmmm....I think enabling the DMA has helped..its seems quicker (running on DMA/100.)

    Also, it seems that the unknown hardware appears to have picked up.

    Still, it boots slowly... About 5 minutes to reach the login screen. Also, when I goto run anything, it seems to take an eternity. An example is the Konquerer web browser. The application windows seems to be resonably quick in loading, but it grinds to a halt for ages when I ask it to load a page.

    Are there any further settings to look at?

    Neil

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    1
    try this

    /usr/bin/powersave -f

    /usr/bin/powersave -c

    basically disables any powersaving features, like speedstep etc.

    I have to do this on my dell 8200 to use any multimedia functions at all. xmms is all choppy if it don't disable the powersaving features.

    Hope it helps.

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22
    Nope...

    Speedstep not supported!

    I'm not having much luck with Linux....I suppose it is working on my desktop in the office!

    I'm not sure what else to do!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •