Ok... first thing I was trying to do today was get my cd burner up and running. So I recompiled the kernel (2.6.6) with scsi emulation ... then make, make modules_install... edited lilo.conf.... rebooted.

So I rebooted the new kernel that i just made... cd burner shows up and that's all good so far i guess, but no sound? I'm thinking what the hell right? doesn't make any sense to me why my sound all of a sudden isn't working. So i figure well maybe i need to set permissions on my snd devices, so i did that. Then i tried running alsa mixer to unmute all the stuff and I get this:

alsamixer: function snd_ctl_open failed for default: no such device.

Now i remember how i fixed this before which was with ./snddevices and created all the devices, but i compiled alsa as modules in the kernel 2.6.6. I tried not compiling alsa as modules but wouldn't let me.

If anyone has any ideas on how to fix this problem, it would be very much appreciated.

P.S. if i load up my old kernel sound still works... weird...