Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
wow, impressive......
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396

    wow, impressive...
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  2. #12
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22
    I've tried removing the $ and # and that just brings up a:

    bash: apachectl: command not found

    I've removed it and am re-installing it. Here is what I do.

    I'm running everything under root.

    I extract the contents of the the directory to a folder.

    Once extracted, I follow the instructions for installation.

    Firstly I run configure in Konsole.

    ./configure

    Its now running through the configuration - best get a coffee!!

    Once this is completed, I run the install. I'm assuming that I can skip the make part as this is a binary distro... (Note: I'm following the instructions @ http://httpd.apache.org/docs-2.0/Install.html.en )

    Ok, all Installed using ./install-bindist.sh

    I get the box up that says You have successfully installed the Apache 2.0.48 HTTP Server....

    Firstly it asks me to check the config (usr/local/apache2/conf/httpd.conf) which I do.

    It then says you can start the server. I use:

    /usr/local/apache2/bin/apachectl start

    I get

    /usr/local/apache2/bin/apachectl: line 67: /usr/local/apache2/bin/httpd: cannot execute binary file.

    So I try

    #/usr/local/apache2/bin/apachectl start

    I get no error..just a new line. So I type ps aux.

    Since I leave the machine on, I get a whole list with various dates. The ones relevent to today display as a time... No sign of httpd. This is after I tried the second command and got the blank line.

    Any ideas? Have I missed something?

    Neil

  3. #13
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Dunno what distro you have but try this as root

    /etc/rc.d/rc.httpd start

    Also have a nose at the log files in /var/www/, see if there's anything interesting there.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22
    I use SUSE Desktop

    Using uname -a I get:

    Linux linux 2.4.19-4GB #1 Wed May 21 18:12:39 UTC 2003 i686 unknown

    I tried what Chris H suggested. The command didn't work and /var/www didn't exist.

    I did notice something when doing uname.

    I downloaded:

    httpd-2.0.48-x86_64-unknown-linux-gnu.tar.gz

    Would this make a difference considering my version states i686

    I assumed I had to use x86 as that is how Intel identify their processors....or am I mistaken?

    Neil

  6. #15
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    is that a 64bit version anyone? looks like it might be from here. Try dling a differnt package and give it a whirl.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  7. #16
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    mcslemon, a question.

    Why are you installing tar.gz files when the suse rpm files are available?
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  8. #17
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22
    Because up until you said that, I wasn't aware of them.

    I downloaded Apache for my Win2k box from the Apache site, so naturally go back there for the linux version.

    I'll take a look at SuSE and see what is there.

    Thanks for all the help, I'll let you know how I do with the RPM.

    Neil.

  9. #18
    Just Joined!
    Join Date
    Jul 2004
    Posts
    22
    Many thanks for all the help.

    Using the RPM from suse.com worked...didn't realise that was available.

    So several library installations and tweaks later the webserver works!

    Now to add the php and mysql modules

    Neil.

  10. #19
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    as an after thought to reading this thread: Everyone in this thread seems to use apache2ctl or apachectl. I have apache on my system and never use that to start it. 'apache2 -k start' gets the job done for me.
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  11. #20
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    he was using a bundle of apahce software I believe.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •