Find the answer to your Linux question:
Results 1 to 4 of 4
Hello everyone, I just installed linux about a week ago and am trying to get hte hang of it. I have fedora core 2, and tried to install tuxracer rpm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    3

    installing tcl


    Hello everyone, I just installed linux about a week ago and am trying to get hte hang of it.

    I have fedora core 2, and tried to install tuxracer rpm from the cd. However it gave me this message:

    error: Failed dependencies:
    libtcl8.4.so is needed by tuxracer-0.61-26

    so.. i went and downloaded the ActiveTcl tarball, i extraced, and found an install.sh so i ran it, and then a window popped up and allowed me to install it in /usr/local/AcitiveTcl/ directory.

    However I still get this message! And on top of that, if i type tcl, or tclsh from the terminal nothing happens. Please somebody help!

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    The package you need is called tcl-8.4.5-7. Should be on CD1
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    what version do u use?if you use suse use yast2 update and in search type tcl.you will be prompted to inert the correct suse installation cd..
    Linux For Ever!

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    3
    Thanks Chris H. The problem was that the tcl rpm on my fedora cd had a bad signature or something, so i had to go get the tcl rpm online.

    But I still am confused. If I were to install from the ActiveTcl installer, what directory should I have installed to? And would I have had to include other directory listings in the library path or some weird linux stuff like that that I know nothing about??

    I like how rpms do everything for you, but I want to learn how to install stuff on my own. Can somebody help me out?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •