Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
hi everyone right in work i have: small network running xp rh 8 samba pc with bind running as a dns so that i can use my intranet servers (apache) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    dns server and router


    hi everyone

    right in work i have:
    small network running xp
    rh 8 samba pc with bind running as a dns
    so that i can use my intranet servers (apache) and lotus domino.

    just installed ADSL router which usb adsl modem plugs into. plug router into hub. everyone now has internet access.

    problem. when configuring clients to access the router have to set the dns server and gateway settings to be the router.

    is there a way of configuring bind to pass unsolved requests to the router?
    therefore I can set the clients to dns from the rh box. and that will pass requests onto the router if they are not internal.

    the Router does not have a static ip from my isp but performs nat automatically for me. I have set each of the clients up with static ips and domain names in the form. pc.titan.iscavision.com, server.titan.iscavision.com etc. but iscavision.com is our external domain name that points to our web server hosted by dsvr.co.uk.

    thanks

    kris
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Why not add a secondary dns to the clients as the router and have the primary dns as the rh8 box.

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That doesn't really work. In my experience (I might be wrong, but I did recently experience this), the secondary-and-so-forth DNS servers are only checked if the first one doesn't reply (ie. can be assumed to be down). If the first one returns an error (such as the domain cannot be found, in this case), that is still authoritative, and the rest of the servers won't be tried.
    Instead, set up a root hint for BIND pointing at the router.
    My setup for this follows; modify it to suit your environment:

    /etc/named.conf:
    Code:
    ...
    
    zone "."
    {
        type hint;
        file "root.hint";
    };
    
    ...
    /etc/named/root.hint:
    Code:
    .       3600000 IN      NS      dns.bonet.se
    dns.bonet.se.   3600000         A       212.181.54.2
    .       3600000 IN      NS      dns2.bonet.se
    dns2.bonet.se.  3600000         A       212.181.54.3

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    secondary dns

    Yes dolda you are correct. i tried that first.

    I'll try the named thing and post the results.

    cheers

    guys
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  6. #5
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    errors

    Hi guys

    right then first thing. didn't work named would start. must be my error.

    can some one explain the format of named files. are they space sensitive should i use tabs etc. i use gedit to create them currently.

    anyway. i have send the two files to my web server. can anyone see what is wrong. I think named.conf is ok I have just sent it up for completeness.

    check them here http://iscavision.com/errors/named.conf
    and
    http://iscavision.com/errors/root.hint

    thanks for this guys
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you saying that named does start properly, but it doesn't work anyway.
    It might be that recursive queries are disallowed. Try adding "recursing yes;" to your options section.

  8. #7
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    correction

    sorry i meant that named doesn't start. gives not useful error of error starting named.

    i will try the recursive thing now.
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  9. #8
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    recursing

    nope that still doesn't allow named to start
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  10. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What kind of errors does it give? Also check /var/log/messages, since that's where named outputs most of its errors.

  11. #10
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    errors

    in var/log/messages

    server name[17367]: starting BIND 9.2.1 -u named
    unknown option recursing
    loading config: failure

    so remove recursing and we get
    zone '.' already exists

    it must be in the named.custom file. so moving on
    located file and commented out existing hint file reference which pointed to named.ca (dunno what this is must have been made by the rh bind config gui)

    restarted named. successful

    changed tcpip settings on clients so gateway is router and dns is rh box.
    cannot locate server for web browsing.

    could problem be:
    my router does not have a fqdn so my root.hint file might be wrong
    it reads
    . 3600000 IN NS router
    router. 3600000 A 150.1.1.2

    is this ok?
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •