Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I have installed an internal isdn modem on a RH9 server as well as squid for a client. The connection is up and users are able to browse the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2

    Demand dialling with internal isdn


    Hi,
    I have installed an internal isdn modem on a RH9 server as well as squid for a client. The connection is up and users are able to browse the internet and pop mail. The problem is that the idle time is 60 seconds as requested by the client and when the connection closes, I have to bring it back up by using the following command:isdnup ippp0. I have also tried to keep the connection up using the command:nohup /usr/sbin/isdnup ippp0 >null 2. The command seemed to have gone through OK but in the message log,I can see the connection going down and no browsing until I run the command:isdnup ippp0. I have also tried editing the /etc/ppp/ioptions file,but when I put the demand line in Linux can't find ippp0. My question is, is there any way to run on-demand dialling from the client side to initiate the dial or keep the daemon running in the background. Any help is greatly appreciated.

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    change the default timeout? what config files did you edit to set up the service, please post them in full here.

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2

    RE:

    I set up the isdn modem in the GUI, as well as setting up the dialup account in the GUI. By doing this it created a device called isdn0.In the /etc/sysconfig/network-scripts I renamed the config file ifcfg-isdn0 to ifcfg-ippp0.In the file I also renamed the device to ippp0.I also edited the the config file /etc/sysconfig/networkin/devices/dialup by changing the device to ippp0 from isdn0. When I ran the command isdnup ippp0 the device would startup and a connection would be made. On startup the device ippp0 startsup but I still have to bring up the connection manually before anyone can connect. Is there any way to get this connection to be started up on demand from a client pc.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •