Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all i am using samba to share a folder created in linux, i am using Win 2000 Server ,every thing is done ,it shows the folder shared when i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Posts
    8

    Samaba problem Red hat 8


    Hi all

    i am using samba to share a folder created in linux, i am using Win 2000 Server ,every thing is done ,it shows the folder shared when i view it in network neighbourhood but when i click the folder it gives Access denied ,and some message in linux terminal about firwall access .....

    Can some one help

    Thank you

    safdar

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Have you added the user to your smbpasswd database?

  3. #3
    Just Joined!
    Join Date
    Mar 2003
    Posts
    8

    Samaba problem Red hat 8

    Well yes i have added the user in the password file
    but still the same problem

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Turn on debugging in smbd by running "smbcontrol smbd debug 6", and see if something useful turns up in the logs. Turn off debugging again with "smbcontrol smbd debug 0".

  5. #5
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    If you are using the linuxserver in a NT-server domain, it depends how you have configured samba, is it joined in the NT-domain or set up as a standalone server, if standalone smpasswd must be runned to match the local passwd file, if you have joined SAMBA with the microsoft domain the user must have a valid NT-account and a local Linux account to match that with + have the right permissions group, etc to realy access the specific share. Look at the sambahowto on:

    http://www.utterberg.com

    and Sambas homepage for more info

    http://www.samba.org


  6. #6
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    domain security

    I am not quite sure how you got this setup but I would run samba as a member server of the windows domain.

    set the security option in the smb.conf to be = domain and the specify the workgroup name to be the win2k domain name and the ip address of the server in the globals area. Then just setup a user account on the 2k server box for your linux account. and that should just work.
    eg.
    [global]
    netbios name = LinuxIsGreat
    workgroup = WORKGROUP
    security = domain
    password server = 1.2.3.4
    encrypt passwords = yes
    os level = 0
    domain master = no
    local master = no
    preferred master = no

    Well you should then be able to open nautilus and navigate to smb://workgroupname and see you server (and other clients).

    now on the 2k server add a machine account for your computer using the pc name you specified in the smb.conf

    then stop smbd nmbd and run this
    # /usr/local/samba/bin/smbpasswd -j WORKGROUP

    This should join the samba pc to the domain.
    Also need to add a user account for the linux account on the 2k pc.


    then you need to create linux user and group accounts for the necessary users and groups and probably a username.map file to convert windows usernames into linux friendly ones. There are scripts for this with samba. and net.exe on win can be used to give you user listings
    Dos prompt:
    C:\net user /domain #will list all users and stuff
    C:\net user scooby /domain # will list specific details about scooby

    If this is not what you wanted then sorry for rambling.
    Good luck

    Kris
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •