Find the answer to your Linux question:
Results 1 to 8 of 8
Linux newbie here. I have just installed Mandrake 10.0 on a LAN with two Windows XP Pro boxes. One of the XP boxes has a shared directory (viewable by the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4

    How to access Windows Drive from Linux


    Linux newbie here. I have just installed Mandrake 10.0 on a LAN with two Windows XP Pro boxes. One of the XP boxes has a shared directory (viewable by the other XP box) called MUSIC which has mp3 files. I am running Apache on the Linux box and would like to create a virtual host that can access the mp3 files on the Windows XP share.

    I know how to set up a virtual host on Apache. My question is how to make the MUSIC share (on the XP box) look like a part of the local Linux file system so I can appropriately reference it in the Apache httpd.conf file.

    I have set up SAMBA on the Linux box, and I can read and write files from an XP box to the Linux box. I don't seem to be able to browse the Windows shares from the Linux box, however. (When I type smb:/ into Konqueror, I see the workgroup and the Windows machines, but when I click on either of the Windows machine names, I get an error: "Share could not be found on given server.")

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    USA, NE
    Posts
    10

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4
    That seems to work, but I'm now having an Apache-related problem. (I'm trying to have a web browser be able to access the shared directory.)

    I've mounted the windows share at /mnt/MUSIC, and added an alias to my Apache config file (alias /music /mnt/MUSIC), but when I try to use the web browser to access, I get an error saying: "You don't have permission to access / on this server."

    When I examine the permissions of /mnt/MUSIC it looks like it should work. It's owned by root, but permissions are set as: rwxr-xr-x.

    Any ideas?

    Also, how do I unmount? When I try umount /mnt/MUSIC, I get an error about the device being busy.

    thanks. --Jeff

  4. #4
    Just Joined! ShadowCat8's Avatar
    Join Date
    Sep 2005
    Location
    San Gabriel Valley, CA
    Posts
    10

    Re: Mounting woes

    I've mounted the windows share at /mnt/MUSIC, and added an alias to my Apache config file (alias /music /mnt/MUSIC), but when I try to use the web browser to access, I get an error saying: "You don't have permission to access / on this server."
    What are the options you have for that directory in your apache2.conf file?

    Also, how do I unmount? When I try umount /mnt/MUSIC, I get an error about the device being busy.
    This usually indicates that something is either using something from (or still in) that filesystem. If nothing is directly accessing anything from that mount at the time you are trying to umount it, then look at all your active terminals and make sure none of them are in the /mnt/MUSIC (or lower) directory. 'pwd' should tell you which directory the terminal you are using is in.

    Hope this helps.


    ShadowCat8

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    Re: Mounting woes

    I am having the same problem, here's my situation:

    I have a linux box running Apache2. Mounted Windows share Filez as /var/www/html/filez, and apache is the owner and has full access.

    When I log in as user apache, I see the files in the mounted folder, no prob. In my apache.conf, i have:

    Code:
    <Directory /var/www/html/filez/>
            AllowOverride None
            Options Indexes FollowSymLinks
            Order Allow,Deny
            Allow from all
    </Directory>
    Now I really don't know what those options mean, but they sounded good to let me in via web. But sure enough, when I try to access http://192.168.1.102/filez/, it gives me the Forbidden message.

    Any help you can give me would be greatly appreciated.

    Thanks!

  6. #6
    Linux Enthusiast
    Join Date
    Jul 2005
    Location
    Maryland
    Posts
    522
    Quote Originally Posted by suprphrk
    Now I really don't know what those options mean, but they sounded good to let me in via web. But sure enough, when I try to access http://192.168.1.102/filez/, it gives me the Forbidden message.
    If you configured apache to use virtual server, add this to the virtual server configuration:
    Code:
    <Directory /var/www/html/filez/>
            Options +Indexes 
    </Directory>
    If the above doesn't work, try these methods:
    http://www.apachefreaks.com/tutorials/24/1.php

  7. #7
    Linux User yourname3232's Avatar
    Join Date
    Aug 2005
    Location
    Pacific Northwest, USA
    Posts
    262
    You may try to "chmod 755 /var/www/html/filez/" or "chown apache:apache /var/www/html/filez/" to see if any of those work.
    Registered GNU/Linux User #399198
    'Experience is something you don't get until just after you need it.' -Steven Wright

  8. #8
    Just Joined!
    Join Date
    Apr 2006
    Location
    bangalore
    Posts
    3

    Smile i had same problem and sorted it...

    Quote Originally Posted by jalperin

    Also, how do I unmount? When I try umount /mnt/MUSIC, I get an error about the device being busy.
    hi jalperin, let me help you. i had the same problems couple of days back.

    01. a common mistake we do is trying to unmount the device, when we are still in the same '/mnt/' or what so ever. first of all, come out of the directory... may be a plain 'cd' will pick you out of these things and place you in your home directory. then try to unmount it. pls try this and lemme know what happened....

    02. and to access all the files in the windows partition, pls go to :
    <http://linux-ntfs.org/> and a little browsing will solve your problem. what we have to do is to install an 'rpm' that exactly suits your system's architecture and then a straight probe will launch all your windows files into your linux system. just that, the file systems are different. ... pls try this and lemme know....

    regards....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •