Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am new to linux I dont have any clue how to play a mp3 file. I am new to rpm's yum and everything please provide me some link to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    6

    [SOLVED] mp3 in rhel


    I am new to linux

    I dont have any clue how to play a mp3 file.
    I am new to rpm's yum and everything
    please provide me some link to play mp3 file in rhel 4

    thanks in advance

  2. #2
    Linux Newbie
    Join Date
    Jun 2006
    Location
    Greece, Athens
    Posts
    214
    Check this post http://www.linuxforums.org/forum/red...-rhel-4-a.html

    Or try vlc. It is a media player that can play many video or audio formats(can even play flv files without extra codecs! Even windows users love it)vlc

  3. #3
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    out of the box you can not play mp3 files because of a lack of codecs. so you need something for that. i find that VLC is one of the best. it plays a whole set of formats(including video).
    if you have a repo that contains VLC then it is just a piece of cake. at any rate you can proceed as follows
    1) check if you have a repo that contains VLC
    Code:
    yum info vlc
    2) if you have , it will return information about the VLC package and you do as follows(and it ends here, you dont need the part from 3)
    Code:
    su -
    yum -y install vlc
    if it does not return anything go to 3)

    3) go here, and download the rpm for your architecture( do not download src.rpm as it needs a little bit of extra work)

    4) go to the folder where you download the package and do
    Code:
    rpm -ivh package_name
    vlc should be installed and it should be possible to play sound. to run it just do
    Code:
    vlc <with out without file_name>
    Linux and me it's a love story

  4. #4
    Just Joined!
    Join Date
    Aug 2008
    Posts
    6

    ya tried xmmx

    Yes
    I tried earlier tried and got the xmms and xmms-mp3 rpm but even after i install it could not play mp3.I think am not good enough in basics to find what is wrong

    So am trying to install vlc as it can play most of the formats.
    Thanks for your inputs

  5. #5
    Just Joined!
    Join Date
    Aug 2008
    Posts
    6

    Thanks khafa

    I did install vlc by following the above steps

    Am able to run too.
    But am getting some error
    VLC media player 0.8.6h Janus
    looking for type: got application/msword
    ALSA lib pcm_hw.c:1155snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
    [00000295] oss audio output error: cannot open audio device (/dev/dsp)


    when i tried playing a file.
    Any idea why
    thanks for your info

  6. #6
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    hi,


    i dont use RHEL with sound (only on servers) so i might be off track but this looks like an ALSA problem to me.
    could you check if the sound card is working properly?
    in newer versions alsaconf is deprecated but it might be used with RHEL 4. so try to make sure that alsa is working correctly and then run vlc again.
    if you have your repos set up correctly you can try to update alsa (or the whole system)
    with
    Code:
    yum update
    Linux and me it's a love story

  7. #7
    Just Joined!
    Join Date
    Aug 2008
    Posts
    6
    yes khafa the sound card should be working properly as am able to listen music online

  8. #8
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    now use fuser and lsof to see if something is holding the device(i foresee ESD).
    for this one i let you dig it on your own so that you can study something from it. just check the man pages
    Code:
    man lsof
    man fuser
    and google for ESD (Enlightened Sound Daemon)
    Linux and me it's a love story

  9. #9
    Just Joined!
    Join Date
    Aug 2008
    Posts
    6
    yes i will try finding this by googling
    Thanks for your time and inputs
    It helped a lot.

  10. #10
    Just Joined!
    Join Date
    Aug 2008
    Posts
    6
    hi khafa
    Ur inputs helped
    I got mp3 playing.Did tried vlc after shutting down some applications and it is playing mp3
    I really thank u for this.Am a newbie and I will try learning much so that I can help others
    Linux forums rock

    bye
    sppraveen

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •