Find the answer to your Linux question:
Results 1 to 3 of 3
I installed qt-3.0.5-17.src.rpm instead of qt-3.1.1-6.i386.rpm on accident. When trying to install qt-3.1.1-6.i386.rpm, it now says: [root@Linux ed]# rpm -ivh /home/ed/Files/qt-3.1.1-6.i386.rpm Preparing... ########################################### [100%] file /usr/bin/qtconfig from install of qt-3.1.1-6 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Ed
    Ed is offline
    Just Joined!
    Join Date
    Jan 2003
    Location
    Texas
    Posts
    59

    Uninstalling RPMs


    I installed qt-3.0.5-17.src.rpm instead of qt-3.1.1-6.i386.rpm on accident. When trying to install qt-3.1.1-6.i386.rpm, it now says:

    [root@Linux ed]# rpm -ivh /home/ed/Files/qt-3.1.1-6.i386.rpm
    Preparing... ########################################### [100%]
    file /usr/bin/qtconfig from install of qt-3.1.1-6 conflicts with file from package qt-3.0.5-17
    [root@Linux ed]#

    I tried to upgrade over the old RPM, and it said:

    [root@Linux ed]# rpm -Uvh /home/ed/Files/qt-3.1.1-6.i386.rpm
    error: Failed dependencies:
    qt = 1:3.0.5-17 is needed by (installed) qt-devel-3.0.5-17
    qt = 1:3.0.5-17 is needed by (installed) qt-MySQL-3.0.5-17
    qt = 1:3.0.5-17 is needed by (installed) qt-ODBC-3.0.5-17
    qt = 1:3.0.5-17 is needed by (installed) qt-PostgreSQL-3.0.5-17
    qt = 1:3.0.5-17 is needed by (installed) qt-Xt-3.0.5-17
    /usr/lib/qt3 is needed by (installed) redhat-artwork-0.47-3

    I need to uninstall qt-3.0.5-17.src.rpm, and install qt-3.1.1-6.i386.rpm. How can I?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The problem isn't that you install qt-3.0.5-17.src.rpm; that has made no impact at all, except putting some files in /usr/src/redhat/SOURCES.
    You will, however, need to upgrade all the other dependencies as well, and you have to do it in one command, as in "rpm -Uhv qt.rpm qt-devel.rpm qt-MySQL.rpm ...". That way rpm will see that all the packages are getting updated, and that all dependencies will be solved when done. Don't you just love RPMs?

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    If the upgrade of thoose packages dont work, the try to remove the rpm that you installed by misstake with:

    rpm -e qt-3.1.1-6

    Make sure that ist called like that with rpm -qa | grep qt


    And then install the correct rpm with rpm -ivh <correct rpm>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •