Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, After years of playing around with windows, decided to check out linux. So I am a very newbie in this. Matter of fact I just started working on linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2003
    Posts
    2

    Update???


    Hello,

    After years of playing around with windows, decided to check out linux. So I am a very newbie in this. Matter of fact I just started working on linux about 2 hrs ago . Installed redhat 7.3 and now I am trying to update my system using rhn_register . I get a message which is posted below.

    This is the first time you have ran rhn_register.
    If you need special network configuration, such as a web proxy,
    please enter that info here.

    0. enableProxyAuth No
    1. httpProxy
    2. proxyUser
    3. proxyPassword



    Enter number of item to edit <return to exit, q to quit without saving>:
    Traceback (innermost last):
    File "/usr/sbin/rhn_register", line 226, in ?
    main()
    File "/usr/sbin/rhn_register", line 141, in main
    text_config.main(shortList=1,message=message,cfg=c fg)
    File "/usr/share/rhn/register/text_config.py", line 188, in main
    value = raw_input()
    EOFError: EOF when reading a line

    Any ideas how to update this system. Please guide me in every possible way.

    Thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Those RedHat utilities are pretty buggy. If you really want RedHat 7.3, go to rpmfind.net and download the latest updater RPM and install it with "rpm -Uhv <filename>" (where <filename>, of course, is the filename that you downloaded). I'm not sure what package it is, but it's probably the up2date package.
    Otherwise, I'd suggest you to download RedHat 9 instead.

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    The REdhat 7.3 distribution is a good one, i havent seen this kind of error on my park...do you execute the up2date as root or as a normal user??

    Regards
    Regards

    Andutt

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2003
    Posts
    2
    I executed the update script logged in as a root user.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •