Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
now how do change the name to dvd instead of cdrom and also how do i get my system to recognize the cdrw thanx for reading...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314

    got it to work


    now how do change the name to dvd instead of cdrom and also
    how do i get my system to recognize the cdrw

    thanx for reading

  2. #12
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't want to complain, but, for the third time: Do you have SCSI emulation turned on, and if so, on what drives?

  3. #13
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314

    nope

    nope i dont that is scsi emulation

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you absolutely sure about that? It would explain a whole lot. What does "cdrecord -scanbus" return?

  6. #15
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314

    ran the command

    Password:
    root@nester:/home/adam# cdrecord -scanbus
    Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
    cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI dr
    iver.
    cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
    cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
    root@nester:/home/adam#


    thats what it returns

  7. #16
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    OK, then. That makes it very strange instead. Anyway, I think you might already have a file called /dev/dvd. If you don't, just create it with "ln -s hdc /dev/dvd".
    You will need SCSI emulation to use your CD-RW (you can read from it without, but you'll need it to write with it). See the CD-Writing HOWTO on tldp.org for information on how to do that.
    But first off the original problem still remains to be solved, right? What happens if you run "mount -t iso9660 /dev/hdc /mnt/cdrom" with a disc in the DVD? Also, if it fails, check your /var/log/messages for any errors from the kernel.

  8. #17
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314

    it works it works it works

    it works finally i watched a dvd on linux last night and it looked excellant

    thanx for you help

    just one more question though

    how do you turn on scsi emulation for the cdrw

  9. #18
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    There are two steps. First, you'll need to make sure that the writer isn't claimed by the usual IDE CDROM driver, by adding "ide-scsi=hdd" to you kernel command line at boot. If your boot loader is GRUB, add it to the end of the "kernel" line in your /boot/grub/grub.conf.

    Then, you need to load the actual SCSI emulation layer, by running "modprobe sr_mod". You can also make sure that it is loaded automatically by adding "alias block-major-11 sr_mod" to your /etc/modules.conf.

    Then run cdrecord -scanbus, to see if it reports your writer.

  10. #19
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314

    its happening all over again but different

    sorry to bother yall with this resolved topic but something else has happened

    first off something happened to my os so i had to reinstall

    heres what i have in my fstab

    /dev/scd0 /mnt/cdrw iso9660 noauto,ro,gid=users 0 0

    and here is the error message when i try to mount the drive

    wrong fs type, bad option, bad supper block on /dev/scd0, or too many mounted file systems

    as far as i know i have the same options turned on as i did before why would it do this now

    when i run cdrecord -scanbus i detects it just fine

  11. #20
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I can't see any FS type in that line?

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •