Find the answer to your Linux question:
Results 1 to 7 of 7
Hello! I'm not that familiar with linux, but tried this anyway: I thought about compiling Android for my Netbook, as everybody writes in the news just now. I found an ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    24

    Ubuntu console: repo command not there?


    Hello!

    I'm not that familiar with linux, but tried this anyway: I thought about compiling Android for my Netbook, as everybody writes in the news just now. I found an awesome tutorial in a google group, but already the first real steps know me out.
    My terminal doesn't seem to know the "repo" command:
    Code:
    ubuntu@ubuntu:~$ repo init -u git://android.git.kernel.org/platform/manifest.git -b cupcake
    bash: repo: command not found
    The tutorial tells me to do that, but I couldn't find any information on what this command does (I guess accessing the repository specified?), so I'm asking here.

    My version of Ubuntu is almost the same as specified in the tutorial:
    Code:
    ubuntu@ubuntu:~$ uname -a
    Linux ubuntu 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux
    ubuntu@ubuntu:~$ gcc --version
    gcc (GCC) 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
    Copyright (C) 2007 Free Software Foundation, Inc.
    Please help me!

  2. #2
    Linux Enthusiast Bemk's Avatar
    Join Date
    Sep 2008
    Location
    Oosterhout-NB, Netherlands
    Posts
    525
    Is repo a package manager?

    If it is I just suggest using apt or synaptic. That is much easier since those are installed in Ubuntu, and those are findable in my software repositories.

  3. #3
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2008
    Posts
    24
    Yeah, the link posted by coopstah13 is exactly what I searched. Thanks

  6. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    1

    error with repo init -u git://android.git.kernel.org/platform/manifest.git

    this is the version of linux that i am using:
    laptop:~/bin/mydroid$ uname -a
    Linux joe-laptop 2.6.24-21-eeepc #1 SMP Thu Aug 7 22:18:05 MDT 2008 i686 GNU/Linux

    everytime i run the command, i get the error below...not sure what is wrong. does anyone have any ideas?

    laptop:~/bin/mydroid$ repo init -u git://android.git.kernel.org/platform/manifest.git -b cupcake
    Traceback (most recent call last):
    File "/home/joe/bin/repo", line 590, in <module>
    main(sys.argv[1:])
    File "/home/joe/bin/repo", line 557, in main
    _Init(args)
    File "/home/joe/bin/repo", line 176, in _Init
    _CheckGitVersion()
    File "/home/joe/bin/repo", line 205, in _CheckGitVersion
    proc = subprocess.Popen(cmd, stdout=subprocess.PIPE)
    File "/usr/lib/python2.5/subprocess.py", line 594, in __init__
    errread, errwrite)
    File "/usr/lib/python2.5/subprocess.py", line 1147, in _execute_child
    raise child_exception
    OSError: [Errno 2] No such file or directory

  7. #6
    Just Joined!
    Join Date
    Oct 2009
    Posts
    1
    I had the same trouble as you had. (also a linux nube)
    repo is a shell script which helps when using git apparently.

    What I found to work was to copy repo to the /bin dir not /home/bin


    It worked for me but i suspect that there is a better way of doing this.

    correction/explanations anyone??

  8. #7
    Just Joined!
    Join Date
    May 2011
    Posts
    1

    downloading repo

    Repo is repository management tool..

    try the below code for downloading ,it worked for me.

    mkdir ~/bin

    curl (kernal link)/repo > ~/bin/repo

    chmod a+x ~/bin/repo
    Now open up your bashrc (nano ~/.bashrc) and add the following to the end:

    PATH=~/bin:$PATH

    Save the file and source it:

    source ~/.bashrc

    if repo is not working restart terminal once and check

    --cheers
    chandu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •