Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I am using FreeBSD. I added some wrong lines in rc.conf. When I reboot: Loading configuration files. /etc/rc.conf: 33: Syntax error: Unterminated quoted string Enter full pathname of shell ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13

    [SOLVED] Can't open linux


    Hi,

    I am using FreeBSD. I added some wrong lines in rc.conf. When I reboot:
    Loading configuration files.
    /etc/rc.conf: 33: Syntax error: Unterminated quoted string
    Enter full pathname of shell or ENTURN for /bin/sh:

    After press ENTER, I am tring to use vi command to change the file
    ex/vi: Error: /var/emp/vi.recover: Read-only file system
    ex/vi: Modifications not recoverable if the session fails
    ex/vi: Error: rc.conf: Read-only file system
    ex/vi: Error: Unable to create temporary file: read-only file system

    Same problem occurs when starting in safe mode.

    Can Any one help me about this?


    Thank you .
    Max

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13

    Smile

    I am using vmware for this FreeBSD system. Is there amy method to modify the file from vmware?

  3. #3
    Just Joined!
    Join Date
    Feb 2009
    Location
    USA
    Posts
    21
    try if you are able to write after executing this command,

    Code:
    mount -o rw,remount /dev/harddisk /

  4. #4
    Just Joined!
    Join Date
    Jan 2006
    Posts
    13
    Thanks for digerati.

    My question has been solved.
    FreeBSD use a different remount command:
    # mount -o rw /dev/ad0s1a /

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •