Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    RE: Physical RAM utilization

    Hi all,

    I'm looking for a second opinion here (or more!).

    We have an Intel PIII server running RH7.1. Initially this server had 4GB of ram with the standard RH7.1 kernel. Over a period of days it would eat all the available physical memory and then start to consume the swap space. One this happened the servers load average would shoot up over 50 and it would inevitably freeze.

    As a test I removed 2GB of memory ... now it only took half the time to go belly up. Next I updated the kernel to the latest 2.4.18-27.7.x. This server is used as an Oracle database server which grabs a hefty 800Mb straight off. So after a reboot the system was using 1.2GB of RAM ..OK.. when our daily backup started on this server the memory usage went right up to use pretty much all available physical memory. At the moment the database is open but the system is not live. It currently looks like so:

    12:48pm up 1 day, 20:38, 1 user, load average: 0.02, 0.02, 0.00

    [root@rh71server01 /root]# cat /proc/meminfo
    total: used: free: shared: buffers: cached:
    Mem: 2114895872 2025791488 89104384 0 26578944 1858322432
    Swap: 2097340416 0 2097340416
    MemTotal: 2065328 kB
    MemFree: 87016 kB
    MemShared: 0 kB
    Buffers: 25956 kB
    Cached: 1814768 kB
    SwapCached: 0 kB
    Active: 1152692 kB
    Inact_dirty: 483456 kB
    Inact_clean: 222680 kB
    Inact_target: 371764 kB
    HighTotal: 1179584 kB
    HighFree: 1024 kB
    LowTotal: 885744 kB
    LowFree: 85992 kB
    SwapTotal: 2048184 kB
    SwapFree: 2048184 kB
    Committed_AS: 867460 kB

    Having read a previous article top command memory question
    in this forum answered in depth by Dolda I believe that I have nothing to worry about here ... however the seeds of doubt have been sown in my mind so I would like to hear from someone who has experienced a similar issue.

    Also do I need to configure this kernel in any way to support a large memory config? If so what params do I need to change?

    Any replies greatly appreciated!

    Don't be surprised if I ask this question again. ...



  2. #2
    Linux Engineer
    Join Date
    Apr 2003
    The kernels below 2.4.19 has documented troubles to manage large memory sizes.

    Iv had the samt problem running big servers on RH 7.3 with oracle with SAN solutions and 4gb RAM. When i changed kernel to 2.4.19 that dramaticly changed to the better, a couple of big fixes on memory and IO handling solved the most of our problems.

    Try to upgrade to that kernel 2.4.19 at least and upgrade to RH 7.3 that i think is the most stable freeware distribution for servers. Otherwise it should not be a problem for memory sizes up to 4gb. Also enable hypertreading on you cpus for better scaleability for Oracles parallel querys.

    Ive migrated about 60 unixserver to Linux that now runs RH 7.3 with 2.4.19 with oracle as a databasehandler, so if you need some more tip just post here or on my site under the forums section.




  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Tby, Sweden
    Well, that's not all, though. I don't know for sure about the RH stock kernels, but I don't think that they come with High Memory support. Check your kernel configuration under Processor Type and Features, and you'll see the High Memory Support option. Set that to four GB and recompile. That should make your memory usage a lot better.
    Also, when the swap started filling up, did you check what process takes it all?

  4. $spacer_open
  5. #4
    Just Joined!
    Join Date
    May 2003
    UK-Heart of Cheshire
    Red Hat 8.0 defininately has high mem support in kernel 2.4.18. This is set at 4GB.

    I would also check with the Oracle boys aswell and raise a TAR. Could be some tuning issues around the DB etc. Is it using Apps?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts