Find the answer to your Linux question:
Results 1 to 9 of 9
Maybe this should be on the Beginners forum i don't know. I am running YDL 6.1 on my PS3 I used to be able to write on my external Hard ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    2

    External Hardrive Issues. I JUST DONT GET IT =*(


    Maybe this should be on the Beginners forum i don't know.

    I am running YDL 6.1 on my PS3
    I used to be able to write on my external Hard drive but not anymore
    I am under the root user
    The Hard drive is mounted and its fat32 format
    When i go to the properties i see
    owner: root
    Folder Access: Create and delete files
    File Access: --- ( <---- i always try to change that to read and write but it goes back to --- )

    I can not create folders on my external hardrive
    i can view file on my external hardrive
    sometime i see little lock symbols on the top right corner of my folders
    when i type "mount" and i check the part relevant to the hd, this is what i get:

    /dev/sda1 on /media/UNTITLED 1 type vfat (rw,nosuid,nodev,shortname=winnt,uid=o)

    It says that i have permission, yet i cant write. what do i do? Please be detailed because i suck at Linux, so step by step would be nice thank you!

  2. #2
    Just Joined!
    Join Date
    Aug 2009
    Posts
    76
    Try adding umask=000 to the options part (rw,nosuid,nodev,shortname=winnt) of /etc/fstab and then reboot. This usually resolves permissions issues.

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    2
    Quote Originally Posted by Zeroangel View Post
    Try adding umask=000 to the options part (rw,nosuid,nodev,shortname=winnt) of /etc/fstab and then reboot. This usually resolves permissions issues.
    What? How? please note that i am a Linux newbie and i do not know what commands will lead me to that option. Thanks for the help

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Unmount partition of External Harddisk using umount command and mount it again using mount command.
    Execute fdisk -l command to check correct device name assigned to partition of External Harddisk :

    Code:
    su -
    mkdir /media/external
    umount /dev/sdbx
    mount -t vfat  /dev/sdbx  /media/external -o defaults,umask=0
    Replace x with number assigned to partition.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Aug 2009
    Posts
    76
    I'm not sure how YDL is set up anymore since I havent used in a long time, but normally what one would do is open the terminal and type in the command

    pico /etc/fstab

    Which would then open a file which looks like this

    /dev/sda1 /media/UNTITLED vfat rw,nosuid,nodev,shortname=winnt,uid=0 0 1

    Spaces are used to seperate the fields (the first one is the device location, the second is the mount point 'media/wardog' the third is the filesystem 'ntfs' and the fourth one is the options)

    You will want to add the text 'umask=000' into the options part so it looks like this
    /dev/sda1 /media/UNTITLED vfat rw,nosuid,nodev,shortname=winnt,uid=0,umask=000 0 1

    That's all you have to do

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by Zeroangel
    You will want to add the text 'umask=000' into the options part so it looks like this
    /dev/sda1 /media/UNTITLED vfat rw,nosuid,nodev,shortname=winnt,uid=0,umask=000 0 1
    There is no need to add this "rw,nosuid,nodev,shortname=winnt,uid=0,umask=000 0 1"
    default,umask=0 0 0 includes all the options and don't use 1 as a value of field. Its fsck value and its not recommended to run it on FAT32 or NTFS filesystems frequently.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Aug 2009
    Posts
    76
    Why is that? I have used it regularly on my windows and other NTFS/FAT filesystems for years without problems. I suppose one can use 111 (to make files on the FS non-executable since one typically doesnt run linux programs or shell scripts from these drives anyways)

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You must be lucky or fsck has been improved by time. A few harddisks hosed up in my lab last year and fsck was one of the problem.
    I suppose one can use 111 (to make files on the FS non-executable since one typically doesnt run linux programs or shell scripts from these drives anyways)
    It your harddisk, data and you can do anything.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Aug 2009
    Posts
    76
    fsck hosed my primary linux ext4 partition two weeks ago (which hasnt ever happened in the 7 or so years i've been using linux). I dont think permissions or umask settings are relevant to that since only my NTFS partitions had the umask settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •