How to -do it , I have done this setttings , I post it on following link also or read the configuration stpes if any problem just let me know.

Aircel gprs with linux pc

Steps
1) connect ur nokia mobile to system

2)Check ur nokia connection as it's vendor and product number
[root@server1 ~]# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 004: ID 0421:0061 Nokia Mobile Phones
Bus 002 Device 003: ID 0e0f:0002
Bus 002 Device 001: ID 0000:0000

3)Add ur modem here with following command
[root@server1 ~]# sudo /sbin/modprobe usbserial vendor=0x421 product=0x061

4)add ur setting with following command
[root@server1 ~]# wvdialconf /etc/wvdial.conf
Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Port Scan<*1>: S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
[root@server1 ~]#
[root@server1 ~]# vim /etc/wvdial.conf
[root@server1 ~]# wvdial
--> WvDial: Internet dialer version 1.54.0
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT+CGDCONT=1,"IP","aircelgprs","",0,0
AT+CGDCONT=1,"IP","aircelgprs","",0,0
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun Oct 4 03:25:12 2009
--> pid of pppd: 9507
--> Using interface ppp0
--> pppd: 60800
--> pppd: 60800
--> pppd: 60800
--> pppd: 60800
--> local IP address 10.183.117.164
--> pppd: 60800
--> remote IP address 10.6.6.6
--> pppd: 60800
--> primary DNS address 202.148.200.3
--> pppd: 60800
--> secondary DNS address 202.148.202.4
--> pppd: 60800
Caught signal #2! Attempting to exit gracefully...
--> Terminating on signal 15
--> pppd: 60800
--> Connect time 7.2 minutes.
--> pppd: 60800
--> pppd: 60800
--> pppd: 60800
--> Disconnecting at Sun Oct 4 03:32:23 2009

add above both nameservers to ur /etc/resolve.conf file
nameserver 202.148.200.3
namesever 202.148.202.4

check the setting again(cross check)
root@server1 proc]# cat /etc/wvdial.conf

[Dialer Defaults]
Modem = /dev/ttyACM0
Init1 = AT+CGDCONT=1,"IP","aircelgprs","",0,0
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Baud = 460800
#Init1 = ATZ
#Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = USB Modem
; Phone = <Target Phone Number>
; Username = <Your Login Name>
; Password = <Your Password>
Username = a
Password = a
Phone = *99#
Stupid Mode = 1

check the kppp pakage and start ur linux in graphic mode with shot the command startx or init 5
click on-->applications-->internet-->kppp
click on configure-->click account tab and click on new-->Manual setup-->dial-->connection name--aircel
clikc add--enter a phone no as put-->*99#--ok-->0k
click on Modems tab-->>New-->Modem name--/dev/ttyAMC0-->modem device-->select /dev/ttyAMC0
now click on Modem tab-->Modem commands-->
Initialization strings1=AT+CGDCONT=1,"IP","aircelgprs","",0,0
Initialization strings2=ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
click -ok
Query Modem to test it-
click ok and ok
put the user name=a
password = a
now connect ur aircel gprs properly
and check sites with firefox mozila
enjoy...........................
Thanks and regards Deepak Ghule