Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    [Solved] fg: no job control error when executing .sh-script

    Hello everyone,

    when executing a .sh-script on our Linux-Server i get the following error:
    ./ line 1: fg: no job control

    The looks like this:

    % java -Xmx256M -classpath sapConnector.jar:lib/GenericConnector.jar:lib/SAPmdi.jar:lib/activation.jar:lib/aii_proxy_rt.jar:lib/aii_util_misc.jar:lib/ant-junit.jar:lib/ant-launcher.jar:lib/ant-trax.jar:lib/ant.jar:lib/aopalliance.jar:lib/aspectjrt.jar:lib/aspectjweaver.jar:lib/bi_sdk_core.jar:lib/bi_sdk_jdbc.jar:lib/bi_sdk_odbo.jar:lib/bi_sdk_olap.jar:lib/bi_sdk_olap_xmi.jar:lib/bi_sdk_query.jar:lib/bi_sdk_rs.jar:lib/bi_sdk_sapq.jar:lib/bi_sdk_xmla.jar:lib/bi_sdk_xmla_dev.jar:lib/boot.jar:lib/commons-codec.jar:lib/commons-collections.jar:lib/commons-logging.jar:lib/connector.jar:lib/exception.jar:lib/grmg.jar:lib/iaik_jce_export.jar:lib/iaik_jsse.jar:lib/iaik_smime.jar:lib/iaik_ssl.jar:lib/iq-lib.jar:lib/jARM.jar:lib/jARMSat.jar:lib/jaas.jar:lib/jaxm-api.jar:lib/jaxrpc-api.jar:lib/jnet.jar:lib/jsse.jar:lib/jta.jar:lib/log4j-1.2.15.jar:lib/logging.jar:lib/logging.perf.jar:lib/mail.jar:lib/
    Where does the error come from (as you can see i don't start the "fg"-command intentionally) and what can i do about it?
    Last edited by balu2000; 10-06-2009 at 03:36 PM. Reason: Solved

  2. #2
    See if JAVA_HOME is set and in your PATH...

    echo $JAVA_HOME

    probably this should correct the error

  3. #3

    That was part of the problem.

    Another problem was, that i forgot to add "#!/bin/bash" at the beginning of the script.

    Now the script can be executed, but i get an exception.

    But that's another story (i will search for that and post a new thread if necessary).

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts