Find the answer to your Linux question:
Results 1 to 10 of 10
Alright, I googled around, I can't find anything about how to get rid of what I'm trying to. In the interest of conserving processor use on a netbook I'm wanting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    28

    [SOLVED] Disabling effects in GNOME


    Alright, I googled around, I can't find anything about how to get rid of what I'm trying to. In the interest of conserving processor use on a netbook I'm wanting to disable a few effects in GNOME, for example, the thing where when you hit minimize, the window zips over to whatever window manager/picker/other you have going, and maybe even bits like transparency changes when I do things. I've disabled Compiz effects, but I'm not sure where to go from there. I'm running eeeBuntu 3.0 on a 1005HA. Thank you kindly.

    -Kit

  2. #2
    Linux Engineer GNU-Fan's Avatar
    Join Date
    Mar 2008
    Posts
    935
    Hi,

    at a deeper level, there are two distinct window managers available for GNOME.
    Compiz, which uses the layered approach for these expensive effects, and METACITY, which is a bit more conservative.

    So first make sure you actually use Metacity, not Compiz.
    Next, run gconf-editor and search for "Metacity" keys. There you play around with the options, like "composition_manager" or "reduced_resources".
    Debian GNU/Linux -- You know you want it.

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    28
    Alright, I tried switching to metacity, and it went as such.

    $sudo metacity --replace
    Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3000003
    Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

    At which point it locks up and I have to restart, if I exit the terminal I have no window manager that works. I did some googling around and found mention of the problem, but no actual solution described. Thank you kindly.

    -Kit

  4. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    If you go to system->preferences->appearance there should be a tab that has desktop effects on it, you can just disable them there.

  5. #5
    Just Joined!
    Join Date
    Oct 2009
    Posts
    28
    I did that, but there's still a few more minor things I'd like to disable, like the window thing, it's like the window turns to a black square and shoots up to the bar.

    -Kit

  6. #6
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    Clicking on no desktop effects there should disable compiz completely. What is output of this?
    Code:
    ps -eaf | egrep "compiz|fusion"

  7. #7
    Just Joined!
    Join Date
    Oct 2009
    Posts
    28
    I appreciate the help. The output is as follows.

    Code:
    $ ps -eaf | egrep "compiz|fusion"
    
    kit            4311  4293  0 00:35 pts/0    00:00:00 egrep      compiz|fusion

  8. #8
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    This means the compositor is not running. So anything you are experiencing wouldn't be due to compiz. Can you describe the problem you are having in more detail or post screenshots? You probably can't post pictures or links with your current post count, so if you upload it to image shack or photobucket put a link to it inside the code tags.

  9. #9
    Linux Engineer GNU-Fan's Avatar
    Join Date
    Mar 2008
    Posts
    935
    Quote Originally Posted by SteamKit View Post
    I did that, but there's still a few more minor things I'd like to disable, like the window thing, it's like the window turns to a black square and shoots up to the bar.
    If I check the "reduced_resources" in the gconf-editor, the transition effect where the window's silhouette is adumbrated when being minimized is disabled.
    Debian GNU/Linux -- You know you want it.

  10. #10
    Just Joined!
    Join Date
    Oct 2009
    Posts
    28
    Oh! Found it in the gconf-editor. Thank you all very much!

    Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •